Need help with error in LibreELEC Kodi: " Settings addon is not yet ready, please try again later..."

  • Hello,


    I have the same problem with libreelec / kodi leia with the current version of libreelec: " Settings addon is not yet ready, please try again later..." as the person in this thread from 2017 "https://forum.libreelec.tv/thread/7350-settings-addon-is-not-yet-ready-please-try-again-later/"


    It's now 2019 and this bug apparently still exists in LibreELEC. Is there a fix for this? I am unable to enter LibreElec configuration. I've tried all the steps mentioned in the other thread from 2017, but after implementing my own settings, I got the same issue again.


    Thanks in advance...


    peanut

    Edited once, last by peanut ().

  • Hello everybody,


    Problem seems to be solved on it's own. I can enter the configuration addon now. I didn't change a thing, but I tried it this morning and I was able to enter this addon again...


    peanut

  • Just went through this same behavior. Although the below is not the solution, but, hopefully, may provide some relief/help to people about this issue.


    What happened is after configuring Bluetooth on LibreElec for a stock RPi3 to pair with a device connected to my stereo system... it worked perfect for a little while. I started to use Radio addon to browse radio stations and one of them made Kodi to crash, forcing it to reload (TV screen black and Kodi splash/welcome page to show up, but not rebooting the RPi).


    From that point, wanted to check config of LibreElec service addon... but got the message in the title ("Settings addon is not yet ready, please try again later..."). I was not able at all to return back to LibreElec addon config... even after 1 or 2 Kodi reboots... gosh!


    Fiddling around (googling, reading threads, etc)... I suspected a bluetooth issue. And here's what I did to "unlock" the LibreElec config addon, from the shell (ssh):

    Using bluetoothctl cli tool, removed the device I added/paired with previously. Issued the command remove 00:02:5A:00:23:D7. Which is in fact removed the device by its MAC address. Quit and rebooted Kodi... LibreElec config addon was now back to responsive.


    I can't say if this is the exact issue, but kinda "solved" that one of this thread for me.


    Thanks,

    Yanhey.