Sync playback to display not working (9.0.2 on Raspberry PI 3+)

  • Hi,

    No matter what I try, I can't get "Sync playback to display" working. LibreELEC 9.0.2 on Raspberry Pi 3+.

    I'm trying to play a 23.976 FPS movie at speed of 25 FPS, with audio speedup and resample. In advancedsettings.xml, I configured the display refresh rate of 25 FPS for videos of 23-25 FPS. The display switches to 25 FPS correctly, but video does not sync to refresh, there is a visible stutter every second. I tried various settings, both types of hardware acceleration on or off, several types of PLL adjustment, several methods of audio resampling and many other settings that could have indirect effect on this situation. Nothing helped.

    So, out of curiosity, I tried LibreELEC 8.2.5. It works perfectly: plays 23.976 FPS movie as 25 FPS without stutter.

    Can anyone suggest if it's even possible to do what I'm trying to do in 9.0.2? What has changed in LibreELEC or Kodi itself that breaks this functionality?

  • Over 3 Months later. Sync Playback to Display still not working.

    I mean, Commodore Amiga was able to speed up video from 24p to 25p and pitch up sound. :)