Oscam, TVH SAT-IP Client , Descrambling only works if I start the channel via VLC first on my PC

  • Hi All,


    Maybe not directly the correct forum..But I see more activity here than on the TVH forum. And because I use Libreelec as my OS for my TV-server and OSCAM-server I hope you can help me out, in trying to solve this issue as google won't help me anymore after 4 days..


    I have the following issue:


    After a few day testing trying etc, I got the SAT-IP connection to my Panasonic client working:).


    But now I have an issue with my descrambling. I have Oscam connection with dvbapi with works fine with my kodi clients.

    But if I select an channel that needs descrambling on satip client. I'm getting the message on my client. Channel is Scrambled.


    The follow message is given in OSCAM:

    2019/06/13 22:11:01 3191AF85 c (dvbapi) Demuxer 0 found 6 ECMpids and 1 STREAMpids in caPMT

    2019/06/13 22:11:01 3191AF85 c (dvbapi) Demuxer 0 found channel in cache and matching prio -> start descrambling ecmpid 4

    2019/06/13 22:11:01 3191AF85 c (dvbapi) Demuxer 0 trying to descramble PID 4 CAID 0604 PROVID 000000 ECMPID 0803 ANY CHID PMTPID 07D0 VPID 07D1

    2019/06/13 22:11:01 3191AF85 c (dvbapi) Demuxer 0 continue decoding of SRVID 4C05

    2019/06/13 22:11:01 3191AF85 c (dvbapi) Demuxer 0 found 6 ECMpids and 1 STREAMpids in caPMT

    2019/06/13 22:11:01 3191AF85 c (dvbapi) Demuxer 0 found 6 ECMpids and 6 STREAMpids in PMT

    2019/06/13 22:11:01 3191AF85 c (dvbapi) Demuxer 0 stop descrambling program number 4C05 ([email protected]:4C05 unknown).


    Messsage on my TvH say's:


    Code
    "SAT>IP Slave/Ziggo/378MHz/Discovery HD" unsubscribing, client="SAT>IP Slave/Ziggo/378MHz/Discovery HD"



    But if I start the same Channel on my PC via VLC (mux channel) the descrambling works on my sat ip client. And even if I switch after 20 sec my channel on my PC (VLC) is stays on working until I switch on a channel on my Sat IP Client.

    So somehow my Sat ip Client is not generating the correct trigger the first time to OSCAM to start decode.. I have google allot but can not find the solution. It should be something simple I think.. But I need to some help in this.


    OScam

    [dvbapi]

    enabled = 1

    au = 1

    pmt_mode = 4

    request_mode = 1

    user = tvheadend

    boxtype = pc-nodmx


    So I'm open for any option.

  • Can you clarify what is client and what is server? It's kind of confusing.

    How is your CA setting on tvh?

    Try changing boxtype = pc.

  • HI Jeanniquini,


    Server = Raspberry PI 2 with:

    TVH version, HTS Tvheadend 4.2.7-44 ~ LibreELEC Tvh-addon v9.0.118
    OSCAM version, oscam-1.20_svn-r11518


    Client = Panasonic TV with SAT>Ip client support.

    Boxtype is change to PC altough no results. For the moment, but maybe I'm asking to much of the PI.


    Got the advise from the TVheadend forum to upgrade to unstable version of 4.28 will try the TVH version,milhouse version as far I know that only one.

  • Change from dvbapi to newcamd and see what happens.

    I do not use satip but I believe that what is happening to you is just a configuration problem.




  • I will try, but it is strange as it work my old config with all my Kodi client.


    Question it the reason for have this oscam config:


    Request Mode: 0 (I have 1)

    ecm.info type: 0 (I have 4)

    Detect channel name: 2 (I have 0)


    Just trying to understand it. As my config works but is based on trail and error

  • Your TV receives the signal from the satellite and works as a satip server, or your rasp have a usb tuner and works as a satip server?

  • Jeanniqui not an app for m3u available for my Panasonic.


    But I'm pretty sure that TvH can do the descramble as SAT>IP server. I even read some topic of people who has working set-up. But I could not get it work...


    Also as I described, the descrambling works is play the same TV Channel via VLC on PC. Than the descrambling on my TV works. So somehow I need tot get the correct signal from TvH to my oscam server to keep the descrambling working.

  • Yes works fine ! Add your newcamd client under cas in tvheadend server settings.

    I have Digibit iptv tuner to my Tvheadend server.

  • Tested it again with version 4.2.8, but same issue. Can't not de-scramble... if start channel first on one of my kodi devices and after that on my TV it works..


    Could be that somehow the SAT->IP server gives an i correct card caid? As my getting card Caid 1868 and normally it should be 0604