Tanix TX6

  • Sorry for delay, but I had to go to work. IT emergency :)


    There is a change, but still doesn't boot :

  • Tested with both u-boot files and works with both.

    Found a HDMI to DVI cable to connect to monitor and kodi is loaded.

    Below are boot and dmesg logs, as test1 is with first u-boot.


    Test1.txt

    Test2.txt

  • Awesome, now detected RAM is 2GB.

    Great! Thanks for testing! I'll add this to AW updates PR, which might be a bit late due to OrangePi One Plus issues.


    Just FYI, half DQ also means lower memory bandwidth, so this also means it might have issues with high bitrate movies.

  • Thanks for warning, but I'll use it with 1080p TV and mainly for SD Live TV.

    One more question. On what depending ethernet to start working.

  • chocho Can you please test this U-Boot for the last time? u-boot-sunxi-with-spl2.bin


    I removed some debug code and I want to be sure I didn't break anything. You don't need to provide output this time if it works.


    Regarding ethernet, it needs some work on kernel side. Driver needs to be written for ethernet PHY, which is probably next thing I will do.

  • Can't boot:


    Code
    1. U-Boot SPL 2019.04 (Jun 29 2019 - 14:46:19 +0200)
    2. DRAM:Unsupported DRAM configuration: column number invalid
    3. resetting ...
    4. U-Boot SPL 2019.04 (Jun 29 2019 - 14:46:19 +0200)
  • I think this was the same as previous, it doesn't boot and version is the same -

    U-Boot SPL 2019.04 (Jun 29 2019 - 14:46:19 +0200)

  • I think this was the same as previous, it doesn't boot and version is the same -

    U-Boot SPL 2019.04 (Jun 29 2019 - 14:46:19 +0200)

    Hm... are you sure you downloaded the right one? The one on the server has U-Boot SPL 2019.04 (Jun 29 2019 - 15:18:14 +0200) in it and the name is u-boot-sunxi-with-spl2.bin (note the "2" in it).

  • Now I am sure, I did it all over again.

    Downloading and flashing:


    and result


    Code
    1. U-Boot SPL 2019.04 (Jun 29 2019 - 14:46:19 +0200)
    2. DRAM:Unsupported DRAM configuration: column number invalid
    3. resetting ...
    4. U-Boot SPL 2019.04 (Jun 29 2019 - 14:46:19 +0200)
  • The file is from 15:18, but can't boot and shows version 14:46:19 +0200

    It is possible that I'm doing something wrong, but can't find where.

    My linux skills are basic, can you tell me how to do that search

  • It is possible that I'm doing something wrong, but can't find where.

    My linux skills are basic, can you tell me how to do that search

    strings u-boot-sunxi-with-spl2.bin | grep "U-Boot SPL"


    Can you tell me which command you are using for burning U-Boot to it?