Tanix TX6

  • Sorry for asking this, but how ... never flashed eMMC.


    Is this the right way?

    Code
    1. dd if=LibreELEC-H6.arm-9.80-devel-20190824143152-5c3df44-tanix-tx6.img of=/dev/mmcblk1 bs=4M
  • Yes, it should work. There is a question if "bs" has optimal size, but it only affects flashing speed.


    Please note that you'll completely overwrite Android. Do a eMMC backup (also with dd) if you ever want to restore it.

  • I can also confirm eMMC is working ... here are two screenshots:


    Code
    1. LibreELEC:~ # dd if=LibreELEC-H6.arm-9.80-devel-20190824143152-5c3df44-tanix-tx6.img of=/dev/mmcblk1 bs=4M
    2. 137+1 records in
    3. 137+1 records out
    4. 575668224 bytes (549.0MB) copied, 2.173960 seconds, 252.5MB/s



    But do not forget to "sync", else you will see this dmesg:

    Code
    1. [ 23.342332] SQUASHFS error: zstd decompression error: 14
    2. [ 23.342358] SQUASHFS error: zstd decompression failed, data probably corrupt

    great work

  • All improvements has been merged into LibreELEC git master, so they will be available in next nightly image.

  • Code
    1. Hello. Installed your image on your TX6 device. Everything is fine, the OS started up, but the processor started to get very hot, the TV screen began to turn off periodically until it turned off completely. I waited until the processor cools down, turned it on, tried to change the graphics modes, but it all repeated. No one had such an effect? There is passive cooling, the native radiator is replaced.
  • Vital_22 Such issue I experienced long ago with different H6 board but not recently. It might be temperature, but that also depends on your cooling solution and ambient temperature. Where I am, ambient temperature is 25°C, what's yours? I never experienced any issues with Tanix TX6. I use stock radiator but housing is removed (only bare PCB).


    Temperature driver will be added at later time, once it's ready for mainline.


    P.S. Please don't use code tag for normal text.

  • It's strange, I have two such TV BOXs, today I launched a memory card with Libreelec on the second TV BOX, there were no problems in operation. On the first device, when the HDMI wire was connected, the TV made a cracking sound periodically. When you connect a second box, on the same HDMI wire, no cod, everything works fine. Android on both boxes works fine, although on the first box the internal memory was previously out of order, this is perhaps the only difference between them.

  • Hard to say what could be wrong.


    Currently we know that Eachlink boxes, albeit very similar to Tanix TX6, have problem with HDMI, to the point that HDMI connector status must be forced to "always connected" with kernel parameter in order to work.


    There are for sure some issues with HDMI, but none of them occurs with HW I own.

  • I hurried up saying that the problem with HDMI was gone. The processor warmed up more under load and, like the first box, the TV began to crack occasionally. However, the second box does not turn off, which is already good. Jernej, I will monitor your work, thanks for the Libreelec image adapted for this box.

  • I will monitor your work, thanks for the Libreelec image adapted for this box.

    Don't forget that I probably won't post new image here anytime soon, unless there is something to test. Use nightlies instead, they are build almost every day and include all improvements.

  • Here is a patch to support WIFI on the Tanix TX6 64GB version with the builitin Cdtech 47822BS (Realtek 8822BS) chip.

    jernej - please have a look at this, it is working for me


    So bluetooth could be on the horizon, because it should be supported by the driver.

  • vitalogy Thanks, but no new Realtek out-of-tree (non-mainline) drivers are accepted in official LE git, as was stated many times already (in Allwinner subforum and github PRs). However, this wifi module has a good chance being supported in mainline soon, as PCIE version is already supported. My info is that SDIO interface support will be added next year. It will be enabled soon as patch(es) will be available.


    If you want to do community builds with wifi driver included and publish images here, it's up to you, but as I said, this package will not be accepted to upstream LE git.

  • Yeah, I saw this in the rtw -driver in mainline, that sdio should supported soon.

    But for now i have wifi ...

    I will pubish a build here, so other can use it, till its in mainline.