LE 9.0.2 freeze when ATI remote is used

  • Hi.

    I have a new bug to report.

    LibreELEC 9.0.2 on Raspberry Pi 3B+.


    I have an old remote control from an old ATI tuner card. This is a radio remote, operates in 433MHz band and has a USB receiver.

    The remote includes "mouse" buttons. They are the big round button on top (mouse movement) and the side buttons for click and right click. Pressing any of the mouse buttons instantly causes LibreELEC to freeze. It won't respond to network ping, ssh session freeze, so I'm unable to provide any crash information.

    All other buttons work (act as intended or just don't do anything): play/stop/skip, arrows (bottom arrows), numbers, volume, etc. They never cause a freeze.


    This remote works with Raspbian and OSMC, including the mouse buttons; they really moved the mouse cursor, clicked, etc.

    I tried other kernel modules.



    Notice that Raspbian and OSMC don't show "ati_remote" driver and register two inputs, not just one.

    Thank you.

    Edited 2 times, last by Marius95: Tested other kernel modules. ().

  • Can you test with the default LE DVB drivers? Wouldn't be the first time one of the media builds (DVD driver packages) causes issues with remotes.


    so long,


    Hias

  • I connected a serial console and this is the error:

  • There is no such file in that directory. There is a file with that name and contents in /usr/lib/modprobe.d/ , but that's read-only.

    Code
    1. RPi:/ # ls /storage/.config/modprobe.d/
    2. disable-spdif-for-hd-audio.conf
    3. RPi:/ # find -name ati_remote.conf
    4. ./usr/lib/modprobe.d/ati_remote.conf


    I tried copying that file in the directory you indicated and removing that line from it.

    IT WORKS!!! No more kernel oops and I can move the mouse! So problem resolved. Please include the fix in the next LibreELEC release.


    One more thing...

    I don't think the kernel should crash even if that file is wrong. If you have time, maybe take a look why it causes a kernel problem? Or report it to the module developer? Or tell me how to report it?

    Thank you!

  • Thanks for reporting back, I'm glad it's working now and I'll add the fix (dropping the modprobe file) for the next release.


    And I agree with you, the driver shouldn't crash if mouse functionality is disabled.


    It'd be best if you sent a bug report by email to Mauro and Sean (the maintainers of the media and rc subsystems) and a CC to the linux-media list:

    Mauro Carvalho Chehab <[email protected]>

    Sean Young <[email protected]>

    [email protected]r.kernel.org


    so long,


    Hias