Libreelec 9.0.1 on Wetek 2 Play doesnt boot anymore

  • Hello together,


    I have been using the Libreelec 9.0.1. build in my NAND for quite some time now (going throw a lot of alpha and beta testbuilds) and it has been working without issues for some time now. I used it yesterday without issues for about 5 hours, and when I tried to turn it on today, i have been welcomed by the safe mode. I googled and found this:

    Kodi failing to read files, needs mediacenter restart - Raspberry Pi - OSMC Forums


    But that didnt help me. Based on the log file I would guess it doesnt load the profile for some reason, but I dont know why! Could someone please tell me how to proceed?


    Thank you,

    Linkin

  • using the forum search I found the same problem here:

    safe mode, and now?


    solved by renaming (moving) /storage/.kodi.FAILED/userdata/profiles.xml to /storage/.kodi.FAILED/userdata/profiles.backup.xml


    Does anyone know how this happened and how I can keep this from happening?


    + bonus question: safe mode did rename my hostname. How can I change this back?

    edit: this was not true (hostname in settings and real hostname was different. However a second reboot did fix the hostname):

    Change hostname?

    Is this a bug or a feature?

    • Official Post

    Safe Mode swaps your (bad) Kodi folder for a temporary (safe) one, so it includes the change to oe_settings.xml where the hostname is stored.

  • It happened again. My guess would be, that my system drive was full and on restart, it tried to rewrite the profile (but no space --> empty file) and therefore has an issue on startup. After deleting the file and some "temp files" its working again.


    Is this possible?