Can't mount NAS (DNS-320L Dlink ShareCenter) no matter what I try, smbclient works fine

  • Hi everyone,

    So I'm hitting a wall here. I've tried modifying my script to include versions 1, 2, not adding a version to no avail.

    I'm simply trying to default mount my share, that's it. It should be easy, but it's not.

    So I've tried the following scripts to mount into a file:


    Yet if I connect using smbclient -U MYUSERNAME //

    I can connect with no issues, browse and such.

    I'm able to connect a wide range of shares directly in libreelec without issue as well.

    But I'm at a loss as to what's going wrong, when I try to test things out on that mount, I get this error

    ● storage-torrents.mount - cifs mount script   
    Loaded: loaded (/storage/.config/system.d/storage-files.mount; disabled; vendor preset: disabled)   
    Active: inactive (dead)    
    Where: /storage/files     
    What: //

    I have very few hairs left to yank out.


  • So


    First I’m stupid.

    I needed to make one tiny modification.

    I guess in LibreELEC, at least the current version on my pi, “Vers” isn’t sufficient. Nope. Needs to be “version” and that seems to have solved the issue.

    Alas it seems I need to create all the other files for their own unique shares.

    Or is it possible to do everything in a single file? Can I mount the various folders there?

    And can someone explain why “vers” didn’t work but “version” did? I followed the wiki to the letter.