Looking for help getting remote control working

  • Hi! I have a nVideo ION based computer on which LibreELEC works great!

    There's one problem though: IR-receiver does not work and I would really appreciate some help to fix that.

    The problem appears to be that it is not detected. I don't anything about nor in dmesg neither in lspci output.

    I have a Windows driver for it and it says its "ITE CIR" and has a splashscreen with "IT8510e" chip.

    The IR-diode is soldered directly on the motherboard.



  • The ITE CIR receiver should be supported by Linux kernels out of the box and you should get an entry in /proc/bus/input/devices and a "rc0: ... " line in dmesg.


    Check if it's enabled in BIOS settings, usually there's some entry with "CIR", on some BIOSes it's disabled by default.


    A BIOS update could also help, sometimes the BIOSes have messed up ACPI tables and Linux won't detect all devices - I have an ancient P4 board here with a connector for an IR receiver and IR settings in BIOS but the ACPI tables don't list it so it's not usable in Linux (manually patching ACPI tables is a possibility, but that's a really deep rabbit hole).


    If you can't get it working please post a full dmesg (dmesg | paste), maybe there are some hints in there.


    so long,


    Hias

  • Thanks for the reply!
    Unfortunately, BIOS update is most definitely out of the question. Tried looking for it but the model is discontinued and the vendor removed all support information from their website. Just in case this PC is Iskratel HD30. BIOS does have an option for switching IR-receiver but it's enabled.


    Full dmesg is attached (too big to paste).

    Files

    • dmesg.txt

      (48.99 kB, downloaded 35 times, last: )
  • As suspected the BIOS has broken ACPI tables.


    On non-broken BIOSes you should see a PNP device with ITE in it's name in dmesg, like this

    Code
    1. [    0.998539] pnp 00:01: Plug and Play ACPI device, IDs ITE8708 (active)


    Back then I tried using different acpi_os_name settings (add it to the cmdline in syslinux.cfg), as suggested eg here https://wiki.archlinux.org/index.php/dsdt but that didn't help. You could try this, too, but don't expect too much - probably not much we can do about it.


    so long,


    Hias