[SOLVED] Cannot playback DVD input/output error

  • Hello,

    it`s me again

    After a long time of absence I checked out the latest LE git yesterday and (fresh) installed it onto my machine.

    All works fine except for DVD playback (again?).

    I already had posted problems of completely missing DVD playback here with an older LE installation, but that got added in the meantime in git.

    I was very suprised that when trying to playback DVD with this version I cannot see any video (shouldn`t it work out of the box in latest versions?).

    This are the relevant parts of the log:

    In my Kodi log I also found some occurences that the input error may come from missing css decryption. The errors were like this (I could only see them when kodi was in debug mode and logged it):


    libdvdread: Get key for /VIDEO_TS/VTS_04_0.VOB at 0x00382cc0
    libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_04_0.VOB (0x00382cc0)
    libdvdread: Elapsed time 0

    I tried some different DVDs, none of them were working. They are all original ones I own. And they are for my region (2 = Europe).

    After that I tried to force region 2 for DVD playback in Kodi settings but that had also no effect.

    I think I did something wrong or forgot something ? But why that ??

    Thanks & best regards,

    Edited once, last by Thomas233 (September 30, 2016 at 9:49 AM).