RPI3 - No HDMI Output if RPI3 is powered before TV is on - no Problem after Reboot

  • edit: two workarounds can be found here:

    RPI3 - No HDMI Output if RPI3 is powered before TV is on - no Problem after Reboot



    Hello,


    I have a very strange issue with the HDMI Output of my RPI3 (however I tried 2 RPI3s and 2 different TVs) - I think this is a Software issue on the Rpi. Same scenario on my Wetek Play2 --> no Problem.


    Steps to reproduce:

    1) Give Power to Rpi3 and TV at the same time (e.g. with a switch)

    2) RPi3 Powers up before my TV can power up

    3) Startup TV and select HDMI channel: no picture/sound via HDMI

    4) RPI is awake and can be restarted with Kore App (ore SSH)

    5) Picture is showing up and everything is running without issues


    As i said: 2 different RPI3s, 2 different TVs - same problem. Same scenario on wetek play2: no issues since about 2 years!


    my guess would be, that on "startup without tv" the follwing screen resolution is choosen:

    720 x 480 with 720 x 480i @ 60.000000 Hz

    This resolution is not in the list when started with TV (only without the i). I tried Libreelec alpha 6,8,9 - is this a known issue? Can this be fixed?


    Thank you,

    Linkin


    attached log with startup without tv (13:05) with issue and startup after reboot with tv (13:14) which works without issues.


    only noticeable difference i find in the log:

    on startup without TV (13:05):


    on startup with TV:

  • Save EDID to a file (tvservice -d edid.dat), copy it to /flash, and put hdmi_edid_file=1 in config.txt.

  • thats for your feedback and tipps! I looked into it more detailed and have a few interesting findings:



    I have a recent andoid TV (from Sony) and it looks, like the android tv needs to "power up" before "answering" to the pi. When I use the "force HDMI Hotplug" option in config.txt, I get HDMI every time, however it only shows a "small picture in the middle of the screen". Its about 640p (instead of the choosen 1080p) - I guess there is a bug?



    I "fixed" it for me by using the boot_delay=20 option in /flash/config.txt. My TV takes something between 15-19s to boot up into android (if i turn it on fast enough, I still see the android tv boot logo). With delay 15s I still get the error, 20s is working reproducable!



    Thank you for the help. I leave it like this for the moment. Will the config.txt be changed via future updates or will it keep the new option?

    Is this "how it should be" or will this be improved for "plug and play users"? Like a "wait x seconds if no hdmi connections is present, otherwise boot up now". That would actually be quite nice, because with this boot delay a reboot takes forever :)

  • For the record: if anybody finds this via search - here a 2 possible solutions:


    I) Solution: Boot up Delay:

    II) Solution: Store the edid.dat and use this if no hotplug is present.

    https://kodi.wiki/view/raspberry_pi_faq#tv_is_not_detected_unless_powered_on_first

    Remark: This only works for the setup you created the edid.dat with.

    If there is any chance in your hardware setup, you have to redo steps 1-4!

  • Hey everyone!

    I have the same Problem on Odroid C2 and the workaround didn't work. I hope you can help me.


    I used libreelec 8.2.5 without problems and it works like a charm.

    My Odroid was allways on and I only shut off the TV. When I started the TV again libreelec was directly on TV.


    Now I upgradet on 9.0.2 and it doesn't work anymore. Now I have to reboot everytime the Odroid after I started the TV.


    I think it RPi and Odroid shouldn't be so different.


    THANK YOU everyone