Automake version error

  • Hello,

    I'm trying to build LibreElec on Ubuntu 18.10. I know I should use Ubuntu 16.04 inside a vm or something but maybe the error I'm getting is trivial to solve for an expert.

    Here's the make output:



    apt tells me that automake is already the newest version (1:1.16.1-1.1ubuntu1).

    I don't know how to point the build system to the newer version of automake.


    Thanks!

  • Basically you need 16.04 or it wont build (or just use master = LE9) - there are a thread here where you get explained what you need to backport to make it work and trash your system at the same time :)

  • Hm... i can't say for 18.10 but i updated all my build machines (8) up from either 15.04 and 16.04 back at the end of the summer to 18.04 xubuntu and have had no issues other then with kodi when it comes to building for any of the Amlogic boxes or for X86_64 Pc's...


    The only issues i have ever run into usually stem from kodi being bumped up from the betas to the release candidates and usually the issue is tied back to the changes made requiring ninja now to build kodi...


    18.04 has automake 1.15.1 not sure if that would help or not. i know ubuntu can be a pain with its packages and i am constantly breaking things by trying to update certain packages and building them from sources but i know just the other day i built the S912 and migrated a S812 project of my own into a fresh 18.04 install onto another build machine and the current le9 (master) git pull built just fine other then Kodi rc2 giving me a couple of issues with ninja and the JsonSchemaBuilder package..


    Ive been using linux since its original release but i feel your pain as i know how tempermental ubuntu can be when messing with its packages/versions. i refuse to use virtual building or docker crap but sometimes its just easier but can say that 18.04 builds fine whether you use the stripped down server install or the xfce desktop.

  • We didn't fixed it for 8.2 as there is no development for it anyway for >1 year already so this has basically zero priority.

    If you make your own build pls switch to "master" with LE9 and save your time with the old old branch.