[SOLVED] Remote Control PCR450 doesn't work

  • I want to use this remote control Portable TV, Portable Freeview Digital TV, Handheld TV, Bluetooth Speakers, Bluetooth Headphones, Bluetooth Receiver, Bluetooth DAB Radio, Clock Radio, TV Aerial with LibreELEC on a Raspberry Pi 3, but it doesn't work.

    The remote control works as a normal keyboard, with raspbian installed or at the Noobs-installer the remote control works!

    The rc works in libreelec only when I switch to mouse mode. Also with debug enabled, at keyboard mode no keypresses are logged!

    I prefer this RC because it has 2 extra learnable IR-Keys for switching TV on/off.

    Some ideas what I could do?

  • I'm not too sure what the problem is - are you saying that mouse mode works but keyboard mode doesn't?


    So firstly lets get some logging info.


    Provide full logs as detailed below. Also include "dmesg | paste" and "lsmod | paste"


    It might show up any issues. However you have to remember that not all remotes are supported and you may just be unlucky.

  • The remote doesn't need special drivers - normally it works as a keyboard. With other OS or the Noobs-Installer the keys are working - only in libreelec is no function.

    Here the logs

    TV-Wohnzimmer:~ # dmesg | paste

    http://ix.io/1h1z

    TV-Wohnzimmer:~ # lsmod | paste

    http://ix.io/1h1a


    lsubs detects the remote as

    Bus 001 Device 007: ID 1d57:ad03 Xenta

  • Well it finds something:

    Code
    1. [ 2.164440] input: FREEWAY TECHNOLOGY as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.2/1-1.1.2:1.2/0003:1D57:AD03.0001/input/input0
    2. [ 2.219037] hid-generic 0003:1D57:AD03.0001: input,hiddev0,hidraw0: USB HID v1.01 Keyboard [FREEWAY TECHNOLOGY] on usb-3f980000.usb-1.1.2/input2
    3. [ 2.223163] input: FREEWAY TECHNOLOGY as /devices/platform/soc/3f980000.usb/usb1/1-1/1-1.1/1-1.1.2/1-1.1.2:1.3/0003:1D57:AD03.0002/input/input1
    4. [ 2.223437] hid-generic 0003:1D57:AD03.0002: input,hidraw1: USB HID v1.01 Mouse [FREEWAY TECHNOLOGY] on usb-3f980000.usb-1.1.2/input3

    Can you provide a full kodi log file - as explained in my signature.


    Also as this is a RPi3B+ can you try a LE9 Milhouse build as it may be related.

  • roedert

    Changed the title of the thread from “Remote Control PCR450 doesn't work” to “[SOLVED] Remote Control PCR450 doesn't work”.