Adding own certs to connect via webdavs/sftp again

  • Has this fix been migrated to other builds too?

    I'm running libreelec on an intel platform and have a need to use a self signed certificate (sophos utm web filtering). Without this certificate present, clients https session are blocked.


  • It's in LE master so any recent LE9-based build will have it. For LibreELEC 8.2.y you'll be dependent on a custom backport.

  • Hello community

    i have tried adding my self signed synology to get webdavs working correctly on the new build 8.90.005

    However, it is warning me: CCurlFile::Exists - Failed: Peer certificate cannot be authenticated with given CA certificates(60)

    So i tried installing certificates. My Synology nas gives me two certificates: synology-ca-cert.pem and cert.pem

    I have tried copying the synology-ca-cert to the /storage/.config/cacert.pem but that lead to this error:

    CCurlFile::Exists - Failed: SSL peer certificate or SSH remote key was not OK(51)

    The certificate is one signed by synology. ( i connect via a name)

    Any idea why this might not be working?

    remark: would it be helpul to once connect to the host via SSL?

    That would ask for the ECDSA key fingerprint and will add it to the list of known hosts.

    Edited once, last by mfrank66 ().