Wi-Fi Dongle Not Working (AC53/AC1200)

  • I recently bought a ASUS AC1200 (AC-53) and connected it to my rpi2 running LE. It doesn't seem to be recognized and I can't figure out how to get it to work. Looking at other forums it looks as though the realtek driver rtl8822bu is not present.


    *Note: I currently have a Dlink adapter connected so I can SSH into the rpi2 (seen in lsusb output).


    Any help would be appreciated. Thanks


  • Realtek provide badly written drivers that don't follow kernel design or quality standards that are never submitted (upstreamed) to the Linux kernel so they are a pain in the rear to sustain over a long period of time. As a result we ran out of enthusiasm for adding more of their crap to our distro several years ago, but if users submit working driver packages to our git repo along with a commitment to maintain the driver for the foreseeable future they will be considered.

  • Thanks chewitt and for all your efforts (I saw several of your replies on the forum).


    Any hardware you recommend that is supported? Need something that supports 5ghz. Your help is greatly appreciated.


    B

  • I cannot recommend brand/model of cards but if you find hardware that uses Atheros chips using the ath9k driver and it will be reliable; the driver is well featured and well supported within the kernel.

  • Hi, just registered so I could ask a similar question.

    RPi2, Librelec 8.95.003.


    I am trying, like the OP to get AC53 (AC1200), not nano version, to be recognised by Librelec, no go; with or without a powered USB hub.

    A D-Link and a TP-Link Wireless N USB Dongle are both recognised immediately (Kudos to the Libreelec team) even without a USB hub.


    I worked out from other threads I need to supply a dmesg log which I have done using putty (once I worked that out...). See below.

    I also tried to supply lspci -k and lspci -nn but both threw an error about not being found.


    Code
    1. QTPi2:~ # lspci -k
    2. -sh: lspci: not found


    The Box has a FLIRC, Wireless Keyboard Dongle and Ethernet-USB Adapter in the USB Ports.

    I then tried lsusb and got the devices listed below - it seems to recognise the AC53 with a Broadcom BCM43526 Chip?


    Could someone kindly point me as to what to do next please? (I also looked at this thread to no avail HTPC Wifi not working ).



  • Hi, me again,


    Well I am now on Librelec 9.0.1 and was hoping the ASUS AC53 (not nano) would be supported but alas, not to be.


    I do note however that this person GitHub - mumixam/LibreELEC.tv: Fork of LibreELEC with package added for RTL8822BU wireless cards (ASUS USB-AC53 Nano) has added a "Fork of LibreELEC with package added for RTL8822BU wireless cards (ASUS USB-AC53 Nano)". This being the case, could I ask whether it would be possible to add the driver package to 9.0.1? If yes, how do I go about doing this please (simply)?


    Thanks a lot,


    k.