Build LE 9 with Kernel Version 4.9

  • Hi all,


    since Kernel Versions > 4.9 i got problems with my Tevii S650 USB DVB-S2 device as desribed here: dw2102 kernel oops

    On first boot i get kernel oops, i think because the device is in "cold" state, the device is not useable. When i restart LE everything is fine, the device can be used to watch TV.


    Milhouse suggested to downgrade the kernel in git (Kodi Community Forum).


    My question is: How do I do that?


    Any help is appreciated


    P.S.:So far I have been able to set up a build host, cloning the master branch from git and building a kernel image for version 4.14.30.

  • did you tried to use an different DVB driver addon at the driver chooser ? the latest (2-3 days old) Milhousebuilds using updated drivers maybe this is fixed (maybe not)

  • You will need to edit packages/linux/package.mk and replace linux 4.14 patches with the patches that are intended for kernel 4.9. You will also need to replace the linux.xxx.conf file with the version that is intended for kernel 4.9. You can copy it from 8.2 branch.

    Edited once, last by smp ().

  • Thanks CvH, but the build does not work, also when the S650 is not connected. Only the Kodi logo and after a while it reboots.

    The crashlog says error in python.

    I think this is the same error as here (see post #23)

    It seems to be related to the current LE9 master and not to the patch.

  • exactly ... meh so we have to wait a bit - next time I try to boot it ;D

    An updated build should work now that Python 2.7.15 has been merged - the Kodi crash is caused by a Python 2.7.14/gcc8 incompatibility.