how to set the deinterlacing method on Intel Hardware (Kaby Lake)?

  • Hey Guys,


    Problem:

    If I play interlaced videos on my rig (mainly live TV over TVhEadend 4.2, dvb-s2, SD mpg2 and 1080i h.264) the best I get is VAAPI-BOB deinterlacin. I can manually set the deinterlacing to something more sofisticated like to motion adaptive from the OSD video menü but every time I change channel it falls back to bob :(


    Question:

    how can I set the preferred deinterlacing method and save it / override bob?

    e. g. over advancedsettings.xml?


    My Setup:

    generic x64 HTPC with an Intel i3-7100 (Kaby Lake)

    LibreELEC 9 alpha (Kodi 18 Leia)

    in settings HQ Scaler 20%, VAAPI activated, for all codecs (MPEG-2, MPEG-4 and VC-1)


    any help appreciated and thanked for.

  • There is also the option in the Video OSD Settings to save the current settings as default.