Problem creating MySQL database on Synology nas

  • Hi


    For some reason i can't get my LibreELEC to create a MySQL database on my NAS. I have a Synology NAS where i have installed phpMyAdmin and the MariaDB 10 on. I have setup a user called kodi with the password kodi and given it all the permissions. I followed this guide from the Kodi forum:

    MySQL/Setting up Kodi - Official Kodi Wiki


    I have been googling for the last two day to try and solve the problem, but i just can't figure out what is going wrong, so now i need help!


    This is my advancedsettings.xml that i placed in the Userdata folder


    I have tried turning on the "Wait for network" option and set it to 30 seconds. My Pi boots up faster than that.

    I also tried manually opening the port 3306 in my Synology Firewall.

    And i also tried creating the Database myself, but nothing is put into the Database.

    I think i just about tried everything i could find and understand on google.


    This is my kodi.log file:

    WDW


    The only thing i did not do in the guide was the export part, since i did not care about that.


    I am running the latest LibreELEC build and just did a clean install tonight to try and start over, but still not working.


    Any suggestions?

  • Check the port. My Synology has mariaDB on 3307 not 3306.

    Dude you saved me! I changed the port and restartet my Pi and then the database was there and now it is filling up with all my media! Thx!