T95Z Plus 3/32Gb display and network problems under 8.90.5

  • Hi,


    I have a Sunvell T95Z Plus with 3/32Gb, same as the OP, and have installed the latest Coreelec 9.0.1, but cannot get the VFD to work. Tried the dtb in post 3 as well, but to no avail. Please help, I know The Coolest has been very helpful to many with various issues, especially getting the VFDs se up. I do not know what's not right, but I tried, both ROM installation and booting from USB flash drive to Coreelec and the DTB file in my opinion seems to be the culprit. Any help is greatly appreciated.

  • You need to use the DTB that's in the 'device_trees' folder on the SD card. Place it on the root of the SD and rename it to "dtb.img".

    After that you just need the config file for your box from the vfd.conf repo on github.

  • Hello The Coolest,


    Thank you for the prompt reply. I suppose I have to use the one named: gxm_q200_3g.dtb

    Then, where do i place the vfd.conf file?

    Thanks again

  • Update,


    Just tried the above mentioned dtb file, even got the vfd.conf file I got from arthur-liberman's repository, placed it in /storage/.config in my device, installed openvfd addon, but still nothing appears on the vfd screen. I must be doing something wrong, I suspect it is the dtb file.

  • DTB doesn't matter. The only requirement is that you must use a DTB file for your device from the `device_trees` folder.

    The vfd.conf file should be renamed to "vfd.conf" and placed in /storage/.config (or Configfiles if you're using SMB shares on Windows).

    Then reboot the device.

    If the clock doesn't come up, post a dmesg log after a reboot

    Code
    1. dmesg | paste