LibreElec on Gemini Lake board - no graphic drivers

  • Hi,


    I'm using LibreElec for a while already on an (very) old Asus AT3Ion board (Atom-processor with ION graphics) in the living room, as well as Kodi on 2 FireTV sticks for the children's rooms and one RPi as playground.

    They access a common MySQL library on a Win10 server and are all running on Kodi 17.x (Krypton).


    Now I bought myself a shiny new Asrock J4105 Gemini Lake board to replace the old atom-ion setup which has quite some performance and thermal issues with HD & Co.

    Unfortunately, it seems like LE/Kodi do not include driveres for the new built-in graphics of the gemini lake processor.


    After long searching the various forums on the internet, it seems like the only solution right now is to jump on an alpha-build of Kodi 18 (Leia) to get the board running.


    Unfortunately, having several clients all running on Kodi18, this does not seem to be the best option as I need all clients to share the same main revision due to the shared movie library/database and I kind of hesitate to put them all on an alpha software.


    Are there any plans to include the drivers for the Gemini Lake graphics to Kodi18? The GL boards start to pop up all over the internet shops, so I'm sure many LE / Kodi users will face the same issue like me...

    Edited once, last by knuti ().

  • isn't that a kodi leia build as well?

    i could try to see if everything works, but if it is, it will update the sql database and my other devices will not run on the same database anymore...

  • Yes it is a K18 build, it is too much hassle (I guess) to backport that kernel to 8.2 .


    To fix your MySQL problems you could use emby instead (no real fix, more an proper replacement). Not sure that helps you much ;)

  • Same problem and mainboard (Asrock J4105 Gemini) here:


    Tried the Milhouse nightly builds but some things (Live TV with tvheadend) aren't working yet.

    Besides in 8/10 cases I wasn't able to start the x-window-manager and didn't see anything so graphics support only works in theory.


    Happy to see it supported in near future ;)

  • CvH


    I did try the image, but it has indeed some issues

    - no startup via USB remote after hibernating

    - VU+ addon not working

    - x-window not working all the time (but my success rate was higher than 2/10)


    so I installed win10 to check how kodi 17 works in general, this works. but it's a shame to have win10 running on a MPC just for Kodi ;-)


    I looked at emby as well, this does indeed look pretty nice; but that's a bigger effort than i want to spend at the moment. I have >3000 movies and ~100 tv series in my database, and i would need to scrape them all again into enby. plus the effort to get all my clients working woith emby incl. played/unplayed status, ...

  • I did try the image, but it has indeed some issues

    - no startup via USB remote after hibernating

    - VU+ addon not working

    thats basically due the pre Alpha of the image


    x-window not working all the time (but my success rate was higher than 2/10)

    what do you mean with that ? crashing or ? The current drivers are a bit unready for that HW at Linux because Intel don't give a damn about Linux.

    If you have the opportunity could you test a normal Milhouse Build with Kernel 4.14 if this works too?


    plus the effort to get all my clients working woith emby incl. played/unplayed status

    the nice thing at emby is that you can just use it with different users :) its basically like mysql but done right


    i would need to scrape them all again

    if you have scraped nfos its a 5min task to get it working ;)

  • what do you mean with that ? crashing or ? The current drivers are a bit unready for that HW at Linux because Intel don't give a damn about Linux.


    once it starts up, it runs until shutdown. but at startup it fails sometimes to start into the graphical interface... hope this explains what happens...

    thats basically due the pre Alpha of the image

    yes, i totally understand, this is why i'm not so keen running a (pre) alpha version in the living room...

    i'm not one of the developers, just a normal user :)


    regarding emby, yes I see the benefits, but i don't have scraped nfo files in my file folders (i guess that's what you ment), just scaped everything into the mysql database. i guess that's not so easy to port into emby, right?


    btw., thank's for your help & patience with my beginner's issues!

  • once it starts up, it runs until shutdown. but at startup it fails sometimes to start into the graphical interface... hope this explains what happens...

    okay tx

    this is why i'm not so keen running a (pre) alpha version in the living room...

    yea not the best idea ;) maybe someone does an kernel 4.15/16 port to LE8.2


    i guess that's not so easy to port into emby, right?

    yes not doable afaik

  • yes, this part seems to work much better than with apollo lake boards. i did just a few basic tests though because of my other issues...

    one thing, it was very important to have my A/V on before turning on the board. otherwise it defaults back to spdif and needs to be changed manually...