RPi2 and LG TV: when switching TV the HDMI channel for RPi comes up

  • This is an old setup that now runs at my dad's home. Used to have Openelec, then libreelec (now 8.2).


    The issue is that now when TV powers up it switches directly to the HDMI channel where the RPi/Libreelec is installed. This confuses my 80-year old dad a bit, can I switch this behaviour off?


    I believe that there was a config.txt option to do that, but utilising it made some functionality (CEC remote support I believe) go away, so I had to revert the change. Not sure though.


    Any help will be appreciated.

  • It is very likely the CEC settings in the RPi that need to be double-checked.

    Go to Settings / System / Input / Peripherals / CEC and toggle off all unnecessary options.