Remote power trouble

  • bumerc

    are this new versions and are they for my H96p+ CZ-S32-v5 ?

    These can be installed on v5 and v6 boards with LPDDR3 memory and are built for testing TheChief. It brings none Advantages for you, it is that you have problems with waking up the box with the activated HDMI-CEC Driver ..?

  • Before i do another test, is there any way to create a backup of the entire Android system including working u-boot, that i can easily flash with Burning tool? Would save much time.

  • I do not like Android and have never been interested, sorry. Replacing the Bootloader via uart takes on average 5 minutes.

  • Before i do another test, is there any way to create a backup of the entire Android system including working u-boot, that i can easily flash with Burning tool? Would save much time.

    Small instructions - backup with TWRP

    1. Download this file (#76) and copy it to the FAT32 partition of the SD card.

    2. Start your box and abort the autoboot by uart connection. (The steps have already been described here.)

    3. Now load recovery.img into the RAM and then start it:

    fatload mmc 0 ${loadaddr} recovery.img
    bootm ${loadaddr}

    4. TWRP Recovery menu should now appear on the display, make a backup of your system.

    good luck

    P.S. Whether the TWRP backup method includes the bootloader, I can not say.

    Edit: Of course you can use the method with hold the reset button.

  • Both versions freezes after some minutes running, I have no more idea and give up. Maybe something is broken and i get another device.

    Yesterday I flashed two other devices with it, both work perfectly. It looks like you have a hardware error.

  • That could be. I just wonder, that the original bootloader works with no problem. I try to get another device.

  • What dtb file you are using?

    EDIT: Google told me it is a gxm_q200 box.

    So the U-Boot.bin should work already. The Android image not - for sure. You can use the CustomizeTool from Amlogic to exchange the U-Boot in your stock ROM. And then use BurncardManager.

    But do it by your own risk!

    In this thread there are the description how to flash the new u-boot using two SD cards and/or the method by the CustomizeTool.

  • Thanks for your suggestion.

    But I think that ddr timings are different from your uboot.

    In other hand, I also use dtb specific for minix u9 release but wrxtasy. It is based on gxm_q200.

    If I flash wrong uboot, it is possible an easily recover of box?


  • Hi.

    Thanks. I'm trying to read u-boot log but I only get this message. What's wrong? I have CoreELEC installed.

    balbes150  wrxtasy Can u help with this issue? Thanks


  • Hey there,

    I tried to fix my u-Boot wit this guide: Remote power trouble

    Unfortunatelly I cant boot from the uboot-recovery-sd with this error:

    As far as I understand it, the u-boot might use the wrong RAM-timing, right? Any suggestions how to fix it?

    Thanks in advance!


  • @toxic-tonic

    What PCB version you have? Blue v5 or v6?

    I got some information from bumerc how to fix this.

    Please try this u-boot:

    [email protected]


    Just create yourself a bootable SD card to test the u-boot before flashing:


    I have done it this way:

    • Create a new LibreELEC/CoreELEC SD card as normal
    • Mount the SD card and write the to sektor 0:
    sudo dd of=/dev/sdb conv=fsync,notrunc bs=1 count=444
    sudo dd of=/dev/sdb conv=fsync,notrunc bs=512 skip=1 seek=1
  • Hey Portisch,

    Thank you very much! I fixed it with your "standard-fixed-uboot". I had to understand that the uboot-file is not loaded from the sd (so not the FILE u-boot.bin) but from sector 0 on the sd. after dd-ing the on the sd it booted rightaway and I burned the u-boot.bin (from you) to the flash as discribed in the post from BUMERC

    Is the new U-Boot you provided above any better?

    The PCB was green and the lable said "CZ | 2G - 16G | 9377" (from memory since my case is already closed)! :D

    So thanks again, now I will test the Poweron-Issue! :thumbup:


  • Hey Portisch,

    Please tell me where in your source is a line or file that responsible for the on / off button code, led indication and ddr4 memory frequency.

    I want to configure the bootloader for my H96Pro+ 3/32 with a board DDR4 v0.2.