Odroid C2, auto rate switching and 24p-defying TV

  • This is my first C2 install, after having some good 3 years on RPi2. I've got a Sammy TV which could support perfect 24p playback. On RPi2 unfortunately, the 24p mode was not detected. So I made a custom EDID file (there's a faq somewhere) and included the relevant option in LE's config.txt file to boot using this speficic EDID info. Doing so, my RPi2 happily switched between 60Hz, 50 Hz and 24Hz!


    After switching to C2 I am encountering the exact same situation: System happily boots up on 1080p60, however TV does not switch to 24p when 24p material is played. It sticks with 60Hz.


    Can I pull a similar trick on C2, like I used on RPi2? That is, trick C2 into thinking that TV can also support 1080p24? FYI, I have enabled the relevant option in the Kodi UI to auto-change rate.

  • cosmos Custom EDID linked above won't work. There's an easier way:

    • login over SSH and execute cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.kodi/userdata/disp_cap
    • edit the file, e.g. nano /storage/.kodi/userdata/disp_cap and add a new line: 1080p24hz
  • Thanks for your fast and informative responses! Been on a trip and just returned, will try your suggestions and get back to you.

  • I implemented the changes, as per your suggestions. There was no /storage/.kodi/userdata/disp_cap before I started. Running cat /sys/class/amhdmitx/amhdmitx0/disp_cap produced the following modes:



    I created the disp_cap file by using

    cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.kodi/userdata

    /disp_cap and then edited the latter file to include 1080p24 and 1080p30 modes. disp_cap contained the following then:



    Note that I did not use any specific order in this file, should I?


    I restarted kodi with systemctl and tried to play some material. Trying both 30Hz and 23.97Hz material did not switch to the relevant mode. Instead Sammy stayed at 60Hz (as depicted when I press the samsung "info" button).


    What could/should I look for?



  • Additional info:


    * Under system -> display settings I am only given options to switch to either 50 or 60 Hz. No 24/30 options at all.


    * Googling around found some commands from ODROID • View topic - AMLOGIC & HDMI , I'm adding here outputs in case it might help here:


  • Yes, of course. BTW, I stated at the start that I had enabled frame rate auto switching. But trying to locate this option I could not locate it. I clearly remember seeing it over the last 3 years or so...

  • I presume you might have exhausted all possible propositions to solve this, but in case you haven't I'm more than eager to give any thought a try :)

  • kszaq I've already enabled expert settings. With age I'm losing my powers of observation though :)


    Would you be kind enough to tell me where exactly I can locate this setting?