s905 - hdmi handshake /color space problem with older TVs

  • - Activate SSH server on your box
    - Connect using SSH client (user: root, password: libreelec)


    Type the following commands:

    Code
    1. cd .config
    2. nano autostart.sh


    This starts an editor. Insert the following text:

    Shell-Script
    1. #!/bin/sh
    2. echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb


    Then save and type

    Code
    1. chmod 755 autostart.sh
    2. reboot


    Your box will restart, and from now on always use RGB output.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test


  • I did everything. I will test it tomorrow!
    thank you.

  • Please describe "lags" further. Is movement jerky, especially when the camera pans right<->left?


    You can try adjusting the settings for video playback: do not activate "sync to display", but set to "adjust refresh rate" with "on start/stop". Depending on your tv, you might have to adjust the time for this refresh rate switch.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test


  • Please describe "lags" further. Is movement jerky, especially when the camera pans right<->left?


    You can try adjusting the settings for video playback: do not activate "sync to display", but set to "adjust refresh rate" with "on start/stop". Depending on your tv, you might have to adjust the time for this refresh rate switch.


    I will try, thank you in advance!


  • Please describe "lags" further. Is movement jerky, especially when the camera pans right<->left?


    You can try adjusting the settings for video playback: do not activate "sync to display", but set to "adjust refresh rate" with "on start/stop". Depending on your tv, you might have to adjust the time for this refresh rate switch.


    "Sync playback to display" is disabled
    "Adjust display refresh rate: on start / stop"


    Where can I adjust the time of refresh rate?

  • Directly under the setting for the "Adjust display refresh rate: on start/stop" is a setting to adjust a small pause for the refresh change to take effect.
    You might need to set settings level to "expert" (bottom left of screen) to see this setting.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • It's not under Settings-Video but it's under Settings-System (expert mode)
    It was to 60 fps, I tried setting it to 50 but it got worse.


    When something moves in the video they lag (seems a fps problem)

  • The setting in "system" is the default refresh rate. If changing this to 50 made it worse, the frame rate switch on playback does not occur. Please check your settings under "Video-Playback"

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • Hi guys,


    the same problem for me.


    I've just bought the MECOOL BB2 PRO Android 6.0 TV Box 3GB DDR4. The TV box is connected to my Philips 32PFL5604H. Tv Set is up to date (last update from Philips is 2010 dated).


    BB2 Pro specifications:


    Brand: MECOOL
    Model: BB2 PRO
    Type: TV Box
    GPU: ARM Mali-T820MP3
    System: Android 6.0
    CPU: Amlogic S912
    Core: Octa Core
    RAM: 3GB
    RAM Type: DDR4
    ROM: 16G
    Max. Extended Capacity: 32G


    In the support forum of others Android Tv Box (this one too) it is suggested to turn on the RGB Option, if present.
    Fortunately this option is present in BB2 Pro...(default disabled)... but If i active this option... it works for a while.


    When I switch between TV Box options screen becomes green again (not always...but often). I switch again in the RGB option (active) and re-active the same option.
    In this way the BB2 Pro turns to work good again. Sometimes... after the green screen, TV Box turns to work well without doing anything.


    I changed the HDMI cable...set to 720p 60hz (from 1080p 50hz)...but nothing.


    The screen turns green even while watching movies with Kodi. Today, for example, about 30 minutes after the start of movie. (1080p 50 hz).


    Here some links to my problem.


    WP_20161225.mp4 - Google Drive
    WP_20161227.mp4 - Google Drive
    WP_20161229.mp4 - Google Drive


    In the Minixforum I found this:

    Quote


    "That issue has to do with the color space the HDMI driver uses for displaying video content. I've seen this before with my Open Hour Chameleon Android based media player and there it was only resolved after the developers gave us the option to select the color space to use. By default they were using YUV444 which isn't the preferred color space of my TV (which seems to use RGB). So when the color space information in the HDMI data stream is missed somehow during display (temporary hickup or timing mismatch) the TV picks the color space it prefers (in my case RGB) and displays the YUV444 stream as a RGB stream. Since the Y component (Luminance or brightness information) is mapped to Red and U and V (which normally encode the color components) are mapped to Green and Blue the picture starts looking like its rendered in Green and Purple shades.
    The only solution for this issue (as de OHC devs discovered) is to give us the options to set the color space used by the HDMI driver. There are no other solutions for this problem for TV's/Displays that use RGB color space by default.
    This issue was also a major problem for UPC's Horizon media boxes and TV's from all major manufacturers (Sony, Philips, Samsung etc) were hit by this until they did the same as the OHC devs."


    Videostrong give me the last firmware available...but nothing change. I wrote several emails to Videostrong support, followed their advice, but nothing has worked.


    A user in another forum says:

    Quote


    "Hi, I have the same problem on a Philips 42PFL8404H/12.
    It seems to be an erroneous AMLogic HDCP 2.2 implementation that doesn't default to HDCP 1.x when HDCP 2.2 handshaking fails as it should for Widewine DRM purposes.
    Hope the next firmware solve this problem."


    How is it possible to resolve this issue?


    Suggestions?


    Thanks


    Magnum

    Edited once, last by Magnum ().

  • Your box uses an amlogic S912 SoC, while the fix we are discussing here is specific for S905(X) SoC. Also the fix is for Libreelec, not Android.


    Currently the box maker is the only one who could help you.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test


  • Your box uses an amlogic S912 SoC, while the fix we are discussing here is specific for S905(X) SoC. Also the fix is for Libreelec, not Android.


    Currently the box maker is the only one who could help you.


    Hi MMPP,


    Thanks for reply.


    I thought to buy a TV box with SoC 905. Then install LE.
    Anything to solve my problem with green screens ... waiting Videostrong solve this problem on BB2 Pro. Or waiting a LE for 912. :D


    I have read this thread: thread-1982.html


    What do you think of the H96 Plus model? Also to minimize the expense.


    It might be fine for LE?


    As said from Kszaq... "My firmware is aimed to work on most S905/X devices. I have no list of boxes that work because except for officialy supported devices I own only 1 S905 and 1 S905X box."


    I accept suggestions ...


    Thanks in advance to all for possible replies.


    Magnum

  • Hello Everyone,


    First of all, i would like to thank mmpp, witokondoria and kszaq and everyone for every effort made here !


    I own a M8S with S905X 2G/16GB and an old TV philips 32PFL6504H


    The issue was the same : green screen. but thanks to everyone a fix was brought with force RGB !


    I was wondering if this fix could be imported in android ?


    i tryed with this


    su
    echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb


    if works write a init.d script to be copied in /system/etc/init.d:


    #!/system/bin/sh


    echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgbGive to it permission 777 and it's ok "


    but the first part could not work : permission denied


    any tip ?


    Thanks again !

  • The android kernel is most likely different from the linux kernel used in Libreelec. As I wrote in the second post of this thread, some android firmwares use


    Code
    1. /sys/devices/virtual/amhdmitx/amhdmitx0/rgb_mode


    You can try using that or check what files exist in that directory. Most newer Android firmwares have the "force RGB" option in the settings, you could try to find an update for your box.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • I have a X96 Tv box S905 Arm with 1 Gb memory
    The installed LibreElec version is 8.0.0b


    My screen keeps turing Green,


    I tried,


    Activate SSH server on your box
    - Connect using SSH client (user: root, password: libreelec)


    Type the following commands:Code:

    Code
    1. cd .config
    2. nano autostart.sh


    This starts an editor. Insert the following text:Code:

    Shell-Script
    1. #!/bin/sh
    2. echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb


    Then save and typeCode:

    Code
    1. chmod 755 autostart.sh
    2. reboot


    Your box will restart, and from now on always use RGB output.


    Did it work, no not for me
    After 15 or 30 minutes the screen turns green, the i switch on the Tv from Hdmi 1 to Hdmi 2 and back and the screen is fine
    And after a while yep the screen turns green again.


    I need help......

  • You can test if the rgb switch helps with your issue by waiting for the green screen and then type the echo command over SSH.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test