Using a USB WIFI Adapter with the Raspberry PI3

  • While the Raspberry PI 3 has built in WIFI, the antenna is not very good and I only get about 70% signal strength. While this is good enough for most functions it is not enough for Live TV in HD coming from my back end running Next PVR. Now I have an external USB WIFI adapter, it is by ANEWKODI, it is dual band (I am using 2.4 GHz as my modem/router does not do 5.8 GHz). It came with drivers for Windows and Mac but nothing for LibreELEC. Now I can plug it in and the OS will see it as WLAN1 (the build in is WLAN0). And I can connect with it and log in and it works great lots of signal strength. But the CONNECTIONS screen might show 100% at first and then it will only show about 30% but I am still getting strong signals, the display just won't show the proper signal strength reading. The real problem comes if I have to reboot, then the connections get all messed up and at first I have no connection and the adapters may switch names 1 for 0 and 0 for 1. I have to remove the external USB adapter and reboot and start all over. It would be nice if in future versions of the OS there was a way to disable the internal WIFI and tell the PI to just use the external WIFI only and to remember all the settings and login info for the connection like it does with the internal WIFI adapter.

    Thank you for a fine product, I have tried other operating systems on the PI 3 and LibreELEC is the best one. Raspbian would not even see the USB WIFI Adapter so I went right back to LibreELEC (used the saved backup to restore the settings and that worked great). 73

  • Thanks for the reply, but I can't find a file called config.txt.

    Where is this file located on the PI3 or is it a file I have to create and if so where should I put it?

    By the way I am running LibreELEC 8.2.1 with Kodi 17.6 the most recent release of the OS.

    Happy Thanksgiving to all !

    Edited once, last by KA2ENE ().

  • OK, I used the edit with another PC method and that does disable the internal WIFI and the external adapter became WLAN0 however after a reboot the external adapter is not connected to my WIFI and has forgotten all of its settings and I have to connect and login and adjust my setting all over again. Is there something else I can add to the config.txt file to make it remember my settings for the external USB WIFI adapter.

    I want to use a static IP address rather than DHCP. I want it to remember my SSID and Password.

    Thanks in advance for all help with this issue.

    Edited once, last by KA2ENE ().

  • I have figured out what is going on with the signal strength reading on the CONNECTIONS screen. I noticed that while my in house WIFI LAN was only showing 30%, signals from my neighbor's WIFI systems were showing readings in the 70% range when they should have been weaker. With the PI 3 in the same room as my WIFI router I should read more than 30% so something is weird here. I am getting great HD Live TV streaming to the PI 3 so I must have better than 30%. So that suggested the following test. The ANEWKODI USB WIFI Adapter has an external antenna with what looks like a SMA connector, so I removed the antenna from the USB adapter which lowered the level of the signal the adapter would receive and low and behold I had a 90% to 100% reading on the CONNECTIONS screen and the signals from my neighbors got very low or just went away. The results tell me that I actually have a signal strength of well over 100% and LibreELECT just can't deal with it and gives a reading of 30% both when the PI 3 is in the same room as the router or farther away from the router. Looks like some tweaks to the signal strength display are needed in the next version of the OS. By the way I am using the Confluence skin, I tried the Estuary skin and had the exact same results.

    • Official Post

    The connections screen GUI reports what connman (the connection manager) tells it, and connman polls the kernel which reads current values from the device driver. So the root cause will be (as normal) in the driver code. I have no knowledge of your wireless hardware, but if it an 802.11ac device there is a 99% chance it uses a Realtek chipset, so the driver code is out-of-kernel and considered to be low quality. LE has no bug to fix.

  • I have the same USB WIFI adapter on my Windows 7 PC running KODI 17.6 and the Utility and Drive software that came with the adapter identify the unit as a REALTEK RTL8811AU 802.11ac WIFI adapter.


    Is there something else I can add to the config.txt file to make it remember my settings for the external USB WIFI adapter.

    I want to use a static IP address rather than DHCP. I want it to remember my SSID and Password.


    Thanks in advance for all the help with this issue.

    • Official Post

    The best way to configure a static IP is to set a static DHCP reservation for the wireless dongle's MAC address in your router. You will still need to join the device to the network when installing - although you shouldn't need to reinstall frequently. It should be a rare event. It is not possible to pre-configure network settings in config.txt.

    • Official Post

    1) The 30 vs 100 signal strength I've noticed before and I think it depends on different images. On some it shows percentage whilst on others it shows DBs - so in reality they are both the same.

    2) The forgetting settings is probably a MAC issue - check journalctl for references to 00:00:00:00. If so, then it's a cheap adapter without a configured MAC address. See Thread