LibreElec 8.0.2 w/ TVHeadend 4.2 updated to any version of LibreElec 8.1+

  • Team.


    Currently running LibreElec 8.0.2 with TVHeadend 4.2 using a WinTV 955Q tuner and all is working good. The tunner appears on TVheadend as a TV adapter LGTD3306A VSB/QAM ATSC-T and ATSC-C with the T option configured and working. Once I update LibreElec to anyother version 8.1 or 8.2 the tunner only shows up as ATSC-T option but when trying any channel from the guide it comes back as No Signal.


    On LibreElec 8.0.2 I’m running TVHeadend 4.2.2.32. When running LibreElec 8.2.0 TVHeadend goes to 4.2.3.20 but again no signal on every channel I tried. I used TVheadend a lot and for that reason I’m stuck in LibreElec v8.0.2.


    Any idea? Am I doing something wrong?

    -embeleco

  • You're doing nothing wrong. I have the same WinTV 955Q tuner and it just doesn't work when I upgrade beyond 8.0.2. The new software just doesn't detect the tuner.

  • I've been planning to install your build. Hopefully I'll get a chance to do it this weekend. Thanks for the reminder.

  • CvH,


    I'm trying to install your generic Build of 8.2.0 but it is failing with the following message:


    "Your system (FAT) partition is too small for this update, and there is not enough space for the update to be installed!.

    You must re-install your system using the disk image of a current release, or you must re-size your existing partitions

    so that the system (FAT) partition is at least 512MB size."



    If I choose the 8.2.0 build directly from LibreElec it goes without any issue. I'm not a guru on linux so any help?


    -embeleco

  • It sounds like you have an older OE era install with 235MB(ish) boot partition? and the update file is more than 95% of the available space so the update gracefully aborts. If that's the case the quickest resolution is to do a backup > reinstall > restore as the reinstall will create a 512MB boot partition. The normal LE image is a little smaller so squeezes under the 5% free space requirement.

  • Installing CvH's LibreElec build for the raspberry pi did the trick. I didn't even have to install any drivers.

    Edited 2 times, last by hn333 ().

  • Thank you CvH, your generic build saved the day (and lots of fruitless troubleshooting!)

    I upgraded to LibreElec 8.2.0 (from 8.0.2) without first reading the release notes - I'm using a WinTV-quadHD tuner. TVheadend showed every mux failed & downgrading LE (and/or TVheadend) did not resolve the issue.

    I backed up, installed your build, restored, and all is well once again. Each of the 4 included drivers worked fine.

  • Me too got the TVH working after instaling CvH's build. Thanks a lot. I'm having another issue now with Recordings.. not sure why it is saying "Not Enough Space" when the /storage/recordings folder is empty right now. I need to do some more troubleshooting.. wife not happy as for some reason her programs were not recorded in the past days. :)


    Again.. thanks CvH.


    -embeleco

  • Hello,


    Just updated my system from CvH's build of 8.2.0 to 8.2.5. (Had no issues with that build of 8.2.0 whatsoever, just trying to remain current). Everything seems to work fine except live TV. TVHeadend interface looks good, but the TV card appears with only the ATSC-T option as mentioned above in the OP. When I attempt to launch live TV is does nothing & after 30 seconds displays "Tvheadend HTSP Client No Signal". For now I will restore a backup of 8.2.0.


    Any advice would be appreciated.