MXQ PRO 4k - LibreELEC won't boot

  • Hello,


    I just bought MXQ PRO 4k and have problem with boot LibreELEC from SD Card.


    I choose the newest one version of image: LibreELEC-S905.arm-8.2-8.1.10.img.gzand prepare SD Card by "dd" command on terminal:

    sudo dd if=LibreELEC-S905.arm-8.2-8.1.10.img of=/dev/rdisk3 bs=4m.


    I found dtb file gxbb_p200_1G_mxq_pro_4k.dtb and used it (change name, replace another on SD main directory).


    Toothpick method start Android System Recovery but LibreELEC won't boot.


    I tried with another versions of LE and tried to use different dtb files (1G, 100M) but it's for nothing.


    What am I doing wrong?



  • What am I doing wrong?

    Try another tool to prepare sd card.

    I use rufus - works perfect on my boxes and raspberrys

  • The recovery screen shows that it is built for a rockchip SoC. You cannot use the amlogic libreelec release with your box.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • @Will_away, @mmpp, @garcea:


    Thank u, for your help. Fortunately, I was able to exchange box to another with s905x on board (btw. box looks identically, thx. chinese). Now everything works perfectly.