BUG: s905x box won't boot properly from powered off state most of the time

  • Hi,


    I have two similar Memobox t95n Mini M8S Pro boxes, both have 2GB but one has 8 and one has 16GB of storage.

    Almost everything works straight away, even the remote (no Wi-Fi though).


    The only issue that I have with both of them is that 9 out of 10 times, when turning it on with the remote, it gets stuck at the Libreelec splash screen. I don't use sleep mode, just regular power states. Network isn't up at that point by then, so I can't reboot from ssh or check logs to see whats happening exactly at that point. I need to unplug the power to get them working again. This has never resulted in a boot failure.


    I've attached debug logs from a couple of weeks ago, so it could be from 8.1.8, but the issue still persists with the current build. Thanks in advance for anything you can find. p.s. I use the gxl_p212_2g device tree.

  • kszaq I think I've found the cause of my problem, now I'm hoping you can find a solution.


    I have an official Microsoft USB MCE remote receiver attached to my box. If I disconnect it, my box seems to boot fine (last six times I've tried all went well).

    If it ain't broken: break it, fix it, repeat

  • Yeah, don't put it into standby.

    Thanks for pointing that out. I don't put it in sleep mode, I power it off. It's still in standby, though.

    If it ain't broken: break it, fix it, repeat

  • Raytestrak are you able to collect logs from serial console?

    By serial console, you mean by RS-232 connection? I'm willing, if you can point me in the right direction. I might have a USB2COM adapter at work, but I getting a laptop with a com port will be more difficult. I'm now 99.99% sure it's the MCE adapter. I haven't had a freeze since I've disconnected it. It's quite an annoying thing to troubleshoot, because I can't connect to the box when it freezes.

    If it ain't broken: break it, fix it, repeat