Posts by Mario77

    If you want kodi to create the passwords.xml on it's own go to settings---services---smb settings and change samba setting from "none" to "smb1"

    Restart...Then go to file manager add source and browse to any location of the new user account you created..give it a name and save...Go back to smb settings on kodi and change back to none and restart again...now go back to file manager and try to access your new source...kodi will ask for username and password....input them and tick "save for this path"...that's it...now you should have the passwords.xml in userdata

    Back for some more help...


    Ok so now I managed to access Libreelec from PC and Vice versa with SMB set to none working still but I m noticing a small hickup when trying to access my PC from Libreelec while PC is sleeping..

    I have wakeonlan enabled...Pc network set to wakeup PC,,wakeonlan.xml on libreelec set but it's only working when I change the source address and wakeonlan.xml to IP instead of host name..

    I understand that there is hosts.config to map ip address to host but not sure how to edit this

    I tryed adding these lines to hosts.config first as shown below ,and then with arrows but none seemed to work...

    try 1: 192.168.0.9 MARIO-DESKTOP

    try 2: <192.168.0.9> <MARIO-DESKTOP>

    Thanks...very clear explanation and everything working as it should...

    In short....add new sources with force SMB 1..."save password for this path" ticked and after that back to force smb to "None" and source is still coming up

    Well 1 problem solved..that is accessing Libreelec from Windows 10..

    Now I cannot access windows 10 from Libreelec...

    I did create a new user account on Windows 10....made it password protected and shared a folder with everyone..

    Now when I go to file manager in kodi on rpi2 to add source and browse to SMB..there is absolutely nothing in there...not even my other Libreelec laptop..

    Tryed the new smb settings in services from None to smb3 and restarter each time and still nothing..

    This is on the latest 8.1.0


    Update:

    I can access windows 10 and PC if I force SMB V1 but not 2 and 3

    Zeroconf also working to access other Libreelec and Windows 10 Creators..


    Should the SMB V2 and V3 be working for me?

    You cannot turn those 2 pins off while there is power to the raspberry pi..

    The only solution would be either a switch for the fan or else you'll have to connect a transistor or relay switch to one of the GPIO to control the fan...I just done mine and is fairly easy...thanks to help I found on the forum..Fan goes on when a set temp is reached...and goes off when minimum temp is reached....never goes on when rpi is on standbye

    Don't think it's the same issue if it was working fine..I would start by resetting cec settings and restart with other tv connected devices unplugged..

    If your using anonymous access (ie. no username/ppasswor and "Everyone" granted access to the Windows share) then this is no longer working as Microsoft have disabled anonymous remote access for SMB shares. You'll now need to create a user with password on the Windows machine, assign the user to the share, then access the share in Kodi via Video > Files which should prompt you for a username/password - enter the username and password of the Windows user, tick the "Remember" box (to save the username/password in passwords.xml) and you should now be able to access the share.

    That is exactly what I'm using...so this setting in local policies is no more valid in windows 10 connecting to libreelec "Network access: Let Everyone permissions apply to anonymous users"

    Ok got it...clear enough ...and no I don't use a password to log in my Pc...so adding user and password protect should do the trick and leave main account with no password...


    Now I still don't understand how to access Libreelec from windows 10..

    I do have a customized samba.config..just added few lines to access Storage without having to login Winscp samba.conf.txt

    Do you think that's the culprit?Is the samba.config enabled in 8.1.0 or sample?

    Now I can't look cause I m back on 8.0.2 cause I cant use 8.1 anyway as Cec is still the same for me...but should be trying it soon hopefully someone will compile and share a rpi2 version with working CEC...