Posts by Glorious1

    To avoid reinventing the wheel a link to the excellent Audio Quickstart Guide in Kodi Wiki should be enough.

    Yes, that table is helpful, and for the very experienced it should be enough, but explanation, interpretation, and recommendation are helpful for the rest of us. But you're right, if it's nothing specific to LibreELEC, it's probably best handled in the Kodi Wiki.

    In the configuration section of the Wiki, there is a wonderful 4K/HDR section on video configuration. It has great detail, very helpful instructions on how to configure the settings in various circumstances, and useful, clear explanations about why. It's some of the best Kodi-related wiki information I've seen.

    I can't find any information on audio configuration though, except Pulseaudio. There are a lot of audio settings and I'm basically guessing with little understanding of what I'm doing.

    Another great idea! Unfortunately no joy. I disconnected the fan, booted, then did Power System Off menu. Pi turned off (no lights).

    Then I renamed that link that mglae had me make, to temporarily disable it, then rebooted. This time, Power System Off caused it to do the pseudo reboot as before: lights off then back on, access light blinks a bit, and it doesn't work.

    You gave me the idea that maybe the HDMI cable was not working right, so I used a different one. Behaved exactly the same.

    That pretty much leaves the Pi itself. Maybe this revision behaves differently, or some little hardware glitsch?

    LibreELEC:~ # uname -a
    Linux LibreELEC 5.10.110 #1 SMP Sat Jan 7 12:15:32 UTC 2023 aarch64 GNU/Linux
    LibreELEC:~ # cat /proc/cpuinfo 
    . . .
    Hardware    : BCM2835
    Revision    : c03115
    Serial        : 100000007bffed02
    Model        : Raspberry Pi 4 Model B Rev 1.5

    This Rev 1.5 apparently has a different PMIC than before. I think that's Power Management something? Hmmm . . .

    Hardware changes in Pi 4 Model B Rev 1.5 ? - Raspberry Pi Forums

    There is a chance that you've connected your fan wrongly, and that has caused your reboot issue. The fan eventually generates some voltage on a pin, which triggers a reboot.

    So whatever fan you have, RTFM, and connect it wisely.

    Thanks, yes that's an excellent thought, so I triple-checked that. For low speed (3.3V), instructions show the red/positive wire going to pin 1 (3.3V) and black/negative to pin 6 (ground). That's the way it is. I would try reversing them just to be sure the fan isn't wired wrong, but the instructions also say if you don't connect it correctly you will damage the fan. It's a tiny 30 mm 2-wire fan.

    You did not mention before you are using a case with fan and likely did install some software intercepting the power off path.

    I didn't install any software or make any configuration changes associated with the fan. Also, one of the troubleshooting steps was booting a fresh, untouched install of LE 10.0.4, and behavior was the same.

    That is to be expected. The halt target only stops the CPU and nothing from the chip set.

    Perhaps you can help me understand further. I've read in several posts that making the changes below with rpi-eeprom-config --edit will result in turning off the 3.3-volt pins (which I'm using) when the system is halted. Seems people have successfully used this to turn off fans when shutting down, but it hasn't worked for me.


    Good to hear. In my link at post #2 I gave instructions, how to power on / off a status LED. That's usable for your fan problem, too.

    Sorry, I couldn't really understand that post, or know what parts of it would apply to the fan.

    I read some posts that say editing the eeprom-config as follows would turn off the 3.3V pins when the Pi is off, but it didn't work for me.

    LibreELEC:~ # rpi-eeprom-config --edit
        [edited in nano]
    LibreELEC:~ # reboot
    LibreELEC:~ # rpi-eeprom-config

    Well I read a bunch of pages on shutdown/poweroff/halt, and they're all as clear as mud.

    So I just went ahead and tried @mglae's suggestion. It works. Now when I click on Power System Off, the LEDs go off and stay off. The TV still goes off, which is good. I'm still wondering why that change was needed for me when it wasn't for others. Perhaps it's my CEC environment.

    Anyway, thanks very much mglae. And thanks to Da Flex for all the troubleshooting.

    Only thing is, the case fan stays on, which I guess is expected because apparently the power to GPIO pins remains on as long as there is power connected to the Pi.

    You can use halt target instead of poweroff target:

    ln -s /usr/lib/systemd/system/ /storage/.config/system.d/
    systemctl daemon-reload

    Okay, thanks mglae, I'll have to look into what is the difference between halt and poweroff. If halt is the equivalent of manually removing power, that won't be an improvement to just switching the power off.

    Meanwhile, I did get a log doing the menu item Power System Off while running the default skin Estuary. The error looks just the same, starting with the button press about 1112:


    Okay, your log instructions above seem to have changed.

    Under Settings > System > Input > Peripherals > CEC Adpater, I'm seeing settings mostly for controlling other devices, not for incoming CEC commands, as best I can tell. Exceptions might be:

    When the TV is switched of --> Suspend

    Action when switching to another source --> Pause Playback

    The second one seems good, but the first one I changed to Ignore. I tried it then several times (with power cycle in between) and using the Power System Off menu still put it into that state of being on but not putting out video.

    I found a file that seems relevant:

    When I changed that TV switched off setting, the line

    <setting id="standby_pc_on_tv_standby" value="13011" />

    changed to a value of 36028. But as noted, that didn't help. The CEC Adapter settings are not documented on the Kodi wiki.

    Thanks. No spare microSD, but I put the image on a USB and was able to boot from that. It behaved just like my regular install. But this gave me an opportunity to study the behavior. Here's what happens when I use the Kodi menu "Power Off System":

    1. TV switches off
    2. RPi main light turns off for ~half second, then back on.
    3. RPi access light blinks a few seconds like it does when booting from power off.
    4. The main light stays on, the fan stays on.
    5. When I turn the TV back on, no video from Kodi. I have to switch RPi off and on again to get it back.

    So it seems to be rebooting with lights and fan on, but not working after, until I power cycle it. Is that what it's supposed to do? Anyway, here's the debug log (note I had to power cycle before I could submit it). It doesn't look like any Kodi log I've seen before.

    I am not saying that to have orderly shutdown, you need hardware switch on io pins. I only told that if RPi is powered off via menu, it will need that switch or other way to cut off power to restart. I did assume that tools addon is required and you are free to fact check me on that.

    So far you kept claiming that Kodi power off does not work without providing any information to investigate it further. If you are here for blue twitter checkmark, they have other blue thing too on some posts. My RPi3B+ does not restart, if I use power off option in Kodi. It shutdowns. I don't remember its firmware version. Original RPi3B+ with 1 meg of ram. It does not have any extra hardware mods.

    Checked Pi 4 Model B Rev 1.2 too. 2023 Jan 11 bootloader. It shutdowns via Kodi menu even without RPi tools addon. Technically hardware is not shutdown. It is halted.

    So I'm getting clear now, that behavior of mine with menu shutdown is not normal. Thanks.

    I don't know what information would be useful. And I have no idea what blue twitter checkmark is; I don't use Twitter.

    LibreELEC 10.0.4

    Raspberry Pi 4b

    I found these commands in another thread; don't know what it means. Bootloader is older than what you referred to, but "latest":

    I don't know. Menu shutdown works for me, so I eventually just have different settings.

    Please login by SSH, and open /storage/.kodi/userdata/guisettings.xml with the nano editor.

    My power management section looks like this. Try the same settings:

    <setting id="powermanagement.displaysoff" default="true">0</setting>
    <setting id="powermanagement.shutdowntime" default="true">0</setting>
    <setting id="powermanagement.shutdownstate" default="true">1</setting>
    <setting id="powermanagement.waitfornetwork" default="true">0</setting>
    <setting id="powermanagement.wakeonaccess" default="true">false</setting>

    Thanks, yes, my powermanagement lines look exactly like that.

    I already have Raspberry Pi tools installed.

    I already have an on-off switch on the power line, and don't need a second one.

    Are you saying Raspberry Pi tools is supposed to provide an orderly software shutdown? It doesn't.

    Are you saying in order to have orderly shutdown, you need to install a hardware switch on those IO pins and make some file modifications?