Posts by HiassofT

    According to this post atvclient didn't work at all until we enabled the appleir driver atvclient working but kodi does nothing


    I 've just kicked off a build without that driver and can upload it tomorrow but I suspect wake-from-suspend will still not work and atvclient won't work either.


    BTW: just noticed that you wrote that wakeup didn't work with 8.0 either and you manually had to add something to autostart: Apple IR Remote (atvclient) not working in v7.90.010 ALPHA


    8.2 uses a newer kernel (4.11 instead of 4.9 in 8.0) so probably some other change(s) might be needed...


    so long,


    Hias

    Sorry, had forgotten that atvclient is built into the image, thought it was an addon.


    To disable it run the following command, then reboot.

    Code
    1. systemctl mask atvclient.service


    To enable it again run this:

    Code
    1. systemctl unmask atvclient.service


    Then, to start it without rebooting this should work:

    Code
    1. systemctl start atvclient.service


    so long,


    Hias

    The previous versions contained no driver for the apple remote at all :-)


    We added the apple-ir driver because we got reports that atvclient no longer worked without it. Also using lirc with the macmini / usbhid driver seems to require it.


    Unfortunately none of us LibreELEC developers have such hardware to test.


    BTW: are you using atvclient? If yes, uninstall it, then reboot, then ssh in, run the command from above and test again if wakeup works.


    IIRC atvclient unbinds the USB device so the command I posted could silently fail. Without atvclient probably only ENTER and volume up / down will be working, but that should be enough to test this. Better connect a USB keyboard during tests though.


    If that works, install atvclient, check if the remote works normally, and then check if suspend / remote wakeup works. Don't reboot in between, otherwise the wakeup settings from manually running wakeup_enable might be lost.


    so long,


    Hias

    One difference is that we enable the apple-ir driver in 8.2.0 - this could be what's causing the issue, although I have no idea why wakeup worked before.


    Could you test if wakeup works after running the following command on 8.2.0:


    Code
    1. DEVPATH="/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8.2/2-1.8.2:1.0/0003:05AC:8242.0001/input/input4" /usr/lib/udev/wakeup_enable


    so long,


    Hias

    What kind of info are you looking for and/or which kind of problem are you trying to solve?


    In general: if you use a typical x86 HTPC box with an integrated IR receiver (like eg a NUC) and an original (or 100% compatible) Microsoft MCE remote it will work out of the box.


    so long,


    Hias

    Try decreasing the command repeat settings in the harmony software as described here: Fixing Repeats


    We recently diagnosed an issue with harmony remotes on kernel 4.14, and it looks like the harmony command feature uses a too long delay (about 240ms between signals instead of the expected ~100ms), setting command repeat to 0 or 1 fixed that.


    so long,


    Hias

    On RPi1 (non-plus model) you also may need to short out the polyfuse F3 - it can contribute to a significant voltage drop.


    Even a very short dip on the voltage rail might make your RPi crash, so if in doubt stick to the official RPi power supplies - they are known to work well.


    Back in the day I had very good success (more than half a dozen installs for friends & family) with official RPi power supply and the following overclock:


    Code
    1. arm_freq=1000
    2. core_freq=500
    3. sdram_freq=500
    4. over_voltage=6


    so long,


    Hias

    The IR receiver device you are using only seems to support the raw lirc protocol - which is a bit odd. Usually IR receiver devices typically support rc-5, rc-6 and nec and some of them in addition to that the lirc protocol.


    Please test with the latest LE beta release (currently 8.1.2). If you still only see "lirc" listed under supported protocols you'll have to use Lirc for remote support - just enable Lirc in LE Settings->Services.


    BTW: Up-to-date instructions on remote handling in LE 8.1 and newer are in the wiki: infrared_remotes [LibreELEC]


    so long,


    Hias

    A small nit:

    Code
    1. dtoverlay=hifiberry-dac

    Is all that should be needed.


    The 2 other lines (dtparam=i2s=on and dtparam=i2c_arm=on) are unnecessary. I2S is automatically enabled by the hifiberry-dac overlay and I2C isn't needed at all. Yes, the internet is full of wrong instructions :-)


    so long,


    Hias

    Try to find out at which exact build the issue started and report that in the Milhouse thread on the kodi forum.


    Other than that: you also seem to have added "dtparam=audio=on" in your confiig.txt so you have both the analog on-board audio of the RPi (bcm2835 ALSA) and the hifiberry card enabled.


    Remove the "dtparam=audio=on" line from config.txt, looks like kodi is struggling when there are 2 audio devices installed.


    so long,


    Hias

    double check that the config.txt line is correct. On success you should get the following lines in dmesg - and ir-keytable should work:

    Code
    1. [ 5.865255] rc rc0: gpio_ir_recv as /devices/platform/ir-receiver/rc/rc0
    2. [ 5.865488] input: gpio_ir_recv as /devices/platform/ir-receiver/rc/rc0/input1
    3. [ 5.876159] rc rc0: lirc_dev: driver ir-lirc-codec (gpio-rc-recv) registered at minor = 0


    If you can't get it working add the following line to config.txt

    Code
    1. dtdebug=1

    Then reeboot and post the output of the following commands:

    Code
    1. paste /flash/config.txt
    2. vcdbg log msg 2>&1 | paste
    3. dmesg | paste


    so long,


    Hias

    dmesg indicates that you have "dtoverlay=lirc-rpi" in your config.txt. Remove that line, use "dtoverlay=gpio-ir" (which is the modern replacement of lirc-rpi) instead and ir-keytable should work.


    so long,


    Hias

    Unfortunately the strace isn't telling us much more than we already knew - sound device doesn't seem to be accepting data (maybe didn't manage to start running).


    I did another test here with LE8.1.2 and still haven't been able to reproduce your issue.


    I used a RPi2 with the PCM5102 based pimoroni pHat, connected ethernet and HDMI cables and a USB keyboard. Then I did this

    - fresh installation of LE 8.1.2 image on SD card

    - after bootup only enabled SSH

    - SSHed in, added "dtoverlay=hifiberry-dac" to end of config.txt, then rebooted

    - copied a 10 seconds wav file (44.1kHz, stereo, 16 bit) via scp to the sdcard

    - SSHed in, ran "aplay -Dhw:0 cd-10sec.wav" about 15 times without any issues


    Try if you can replicate using the exact same setup and steps. If you get issues my best bet is some hardware/cabling issue with your soundcard or an issue with your power supply (the number one cause of mysterious problems on RPi).


    so long,


    Hias

    You can't turn on your RPi via the IR remote.


    There are addon boards which allow you to do this - you need a small microcontroller that's running when the RPi is off that "listens" for a power-on IR button press and then turns on power to the RPi.


    But considering that the costs of these boards is about the same as the electricity costs of having your RPi continously on for 3-5 years it's debatable if they are actually useful.


    so long,


    Hias

    You can do that by masking the kodi systemd service, plus maybe some others you don't need/want (eventlircd etc)

    Code
    1. systemctl mask kodi


    Only drawback is that then you have to care about addon updates / installation yourself.


    Search the forum, we've discussed that before.


    so long,


    Hias