Posts by mmcmonster

    This is still a problem in January 2022.
    This is the error I get:

    Code
    2022-01-09 13:47:41.270 LibreELEC USB-SD Creator[68642:1734204] XType: com.apple.fonts is not accessible.
    2022-01-09 13:47:41.270 LibreELEC USB-SD Creator[68642:1734204] XType: XTFontStaticRegistry is enabled.
    PasteBoard: Error creating pasteboard: com.apple.pasteboard.clipboard [-4960]
    PasteBoard: Error creating pasteboard: com.apple.pasteboard.find [-4960]
    2022-01-09 13:47:41.682 LibreELEC USB-SD Creator[68642:1734204] The application with bundle ID com.apple.ScriptEditor.id.LibreELEC is running setugid(), which is not allowed. Exiting.

    I'm not seeing anythng in the issue report that says it is an older Atom/ION machine? - but if iit was, ION = nVidia and there is no support for nVidia GPUs in LE11 'Generic' images so you'd need to self-compile the 'Generic_Legacy' version (while this is still possible).

    Yes, this is an older computer. Here's a link to it from Amazon. It's an Intel Atom D525 with nVidia Ion graphics.


    So I guess it's not supported by the default builds? That makes some sense. :-/

    what happens when you put the *.tar in ~/.update/ ?


    wasn't the *.gz for creating a usb stick only ?


    anyway: *.03893cb.tar works here

    Just put the LibreELEC-Generic.x86_64-11.0-nightly-20211205-03893cb.tar in ~/.update and ran into the same problem. It hangs on the boot at LibreELEC (community): nightly-20211205-03893cb line for a couple minutes and then reboots itself.

    Thanks. I'll try the next few nightlies and cross my fingers.


    I'll keep the SYSTEM and KERNEL files from 10.0.1 handy in case it doesn't work. They should upload faster than the whole .img. 😁

    So I'm trying to install a nightly (for the first time) to see if it will fix a problem with my IR receiver crashing.


    I went to https://test.libreelec.tv/ and downloaded LibreELEC-Generic.x86_64-11.0-nightly-20211205-03893cb.img.gz and put it in my ~/.update directory. It was installed on the next reboot and the system rebooted...


    ...and the system never came up. It stayed on the booting screen saying it was loading the nightly (probably for a couple minutes) and then just rebooted. I let it do this through a couple reboots and then remotely uploaded my previous working image (LibreELEC-Generic.x86_64-10.0.1.img) and the system unpacked it and things got back to normal (after initially booting into a safe mode).


    Was I unlucky and just download a bad build? Or did I miss something?

    Sporadically, my IR remote doesn't work with Kodi. It's a problem with Kodi because the remote works with everything else (ie: TV, receiver).


    When I reboot Kodi (by remote login and "sudo reboot 0"), the IR remove works again, just as if nothing happened.


    Running 10.0.1. Problem started around the time of the 10.0 betas, I think.


    Pretty sure it started when I tried installing a Netflix add-on for Kodi. I subsequently got rid of the add-on, and the problem never went away.


    If nothing else, is there a way to reboot the IR subsystem without rebooting the computer?

    You press ENTER to save the file.


    In nano you can save the file at any time with CTRL-o (hold down the Control key and press o). When you do so, it will ask you for the file name, but it will already be prefilled, you can just hit the ENTER key.


    You can then exit with CTRL-x (hold down the Control key and press x).


    Once you exit nano with CTRL-x, exit PuTTY with 'exit'.

    (In Filezilla, make sure the Protocol is set to SFTP, not FTP.)


    Question:

    When you remote it with PuTTY, does entering the following two lines re-enable your audio?

    Code
    xrandr --output HDMI-1 --mode 1920x1080 --rate 59.94
    xrandr --output HDMI-1 --mode 1920x1080 --rate 60.00

    Here's the entire thread I posted back in 2019. Post #32 contains the script that worked for me. Unfortunately, it stopped working a few months later.


    No Audio after wake from suspend

    Thanks for the link. Sounds like I have almost the same solution. 😁

    I think xrandr changed it's options and if you add the hyphen to HDMI-1 it should work again.


    I used my script and suspended and resumed a few times and things are working great for me.


    Thanks again for pointing me in the right direction. 👍

    Using the above, I think I have a solution. When awaking from suspend, I will kill Kodi so that it will restart and rescan the database. I will then change the refresh rate and then change it back a couple seconds later.


    Works so far. 🤞


    /storage/.kodi/addons/00restart/sleep.d/restart.power

    Bash
    #!/bin/sh
    [ "$1" = "post" ] && sleep 5 && kill -9 `pidof kodi.bin` \
    && xrandr --output HDMI-0 --mode 1920x1080 --rate 59.94 && sleep 2 \
    && xrandr --output HDMI-0 --mode 1920x1080 --rate 60.00


    If it doesn't work, I would check if xrandr gives the same results before and after suspending.

    Thanks for the hint. It definitely worked on the UI. I have to give it a try on the commandline. But somehow doing it once on the UI fixed it for me. 🤷‍♂️


    For future reference and for others that are running into the same problem, this is how to change the refresh rate to 59.94 and then back to 60.00 on the command line:

    Code
    xrandr --output HDMI-0 --mode 1920x1080 --rate 59.94
    xrandr --output HDMI-0 --mode 1920x1080 --rate 60.00

    Problem: My nettop box doesn't restart the audio driver when awaking from Suspend. Because the computer doesn't respond to IR when completely powered down, I have to reboot after waking from suspend.


    This is how I currently do it:

    /storage/.kodi/addons/00restart/sleep.d/restart.power:

    Bash
    #!/bin/sh
    [ "$1" = "post" ] && reboot


    Is there a better way to restart the audio driver than rebooting the entire system?


    I tried killing kodi.bin, but that doesn't work. It looks like I have to restart the kernel. Not sure how to do that without ``````"reboot". Or is there a way to restart the audio subsystem? :(