Posts by SirMacke

    I don't think anything is wrong. It probably just idles at 800 MHz and scales up to whatever is needed. SirMacke said it's "stuck" on 800 though. He should run an HD video and check the CPU speed at the same time.

    Ot is always on 800. Mkv, youtube, netflix. Cores at 100% and still only 800.

    That is the video clock of the GPU.


    Use

    Code
    1. cat /sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_cur_freq

    to see the current CPU core frequencies.

    cat: can't open '/sys/devices/system/cpu/cpu*/cpufreq/cpuinfo_cur_freq': No such file or directory



    Edit:

    Code
    1. LibreELEC:~ # lscpu | grep MHz
    2. CPU MHz: 799.149
    3. CPU max MHz: 1500.0000
    4. CPU min MHz: 800.0000

    But It never leaves 800, even when cores are at 100%

    Run this command in ssh:

    Code
    1. cat /sys/devices/system/cpu/cpufreq/policy0/scaling_governor

    If is says "powersave" - run this:

    Code
    1. echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor

    If this solves your issue you can make it permanent by adding it to /storage/.config/autostart.sh


    Added to autostart.sh and confirmed on performance now, it was on powersave.

    But still max 800Mhz and maxing it when Netflix is on.


    Also tried:


    (

    echo 750 > /sys/devices/pci0000:00/0000:00:02.0/drm/card0/gt_min_freq_mhz

    ) &

    nohup script.sh &



    I don't see any difference.

    But then that might not be the correct device for my nuc.

    So I have a Intel NUC: NUC6CAYH

    CPU is a Intel Celeron J3455 / 1.5 GHz / 2.3Ghz turbo.

    But in LibreElec / Kodi (19) it is stuck at 800Mhz.

    I have checked everything in BIOS but all settings are at high perf.

    If I only swap the disk and boot Windows, speeds are ok.

    How to solve this?