Posts by FeFiFoFum

    Kodi can use SMB from within Kodi. Plex (in docker) cannot access mounts via Kodi. So mount in the OS and then configure both Kodi and Plex to use the same /storage/mountpoint(s) for the remote SMB/NFS shares.

    Thank you for replying again!


    Sorry for more dumb questions,......... I've found a tuturial on how to mount an SMB, including editing several files and rebooting.

    However, I'm curious if I can just do testing first and mount an SMB share, without a reboot? (initially)


    I've tried this command, which IS working on my Raspberry Pi.
    mount -t cifs //192.168.0.9/testsmb /tmp/bob


    It's not working on LibreElec though :/

    It's spitting back "invalid argument" at me.

    So I figure the synatx for the mount command, in LibreElec is different (slightly) to the syntax of mount command in tutorials I'm finding across the web, for Linux.


    Hopefully this thread helps someone else too.

    Thanks both of you guys, to clarify, I imagine this means there's no way to do this (currently) in LibreElec front end interface, need to be smarter users SSH'ing in and what have you?


    (I'm ok with that, I just was curious if there's a simple solution)



    EDIT: Also, does anyone know, the precise command syntax I can do, for testing in the SSH session, before writing the file?

    I do not have a user / pass (guest access) so it's a little bit unclear in the doco, hence wanting to fiddle



    (My emphasis on a few lines there)

    I'm having precisely this problem with mine, I've just started using LibreElec, I'm so very very impressed so far, but stuck at this point, identical issues. (I use SMB, not NFS)


    My SMB pointers in my XML file, in Kodi, which are obviously working for Kodi - as soon as I configure them to be the 'redirects' for Plex in the Plex config, will stop the Plex docker executing and running.


    I can confirm this by SSH in, then typing in

    docker image ls

    and

    docker container ls


    The container is pulled down, but it's not running, unless I reset those settings to default, then it's listed as running.


    So what's the easy solution?