Posts by edjalmo

    thoradia

    I remembered something...

    When I was search about set memory limits I found this: Resource control with systemd • /dev/schnouki

    At that time I test but don´t worked, because, I think, the cgroup_enable=memory was not set. Maybe this is a solution for us!

    This consist on set a memory limit for a group of services. I think this way we can set something like MemoryMax=400Mb for Sonarr, Radarr and Jackett.

    I think if we set this, when Jackett have to update it will crash another services (sonarr, radarr) and after this back to normal!

    I don't know if work this way, but maybe it work :)


    I have set MemoryMax=300M for Jackett to enable auto-update

    Perhaps is better test this way now and see the results before try this.

    edjalmo


    Jackett auto-update fails if MemoryMax is too low

    I have set MemoryMax=300M for Jackett to enable auto-update

    If auto-update breaks your system then disable auto-update

    After you said this I check my Jackett, and it are in 0.10.778.0 version (being that the current version is v0.11.8).

    I think it will freeze and I´ll have to disable auto-updates :/

    Is it possible to transfer my previous couchpotato settings file to the thoradia couchpotato? I am really not in the mood to redo the entire thing.


    I have my old couchpotato.ini file but cant seem to find where I need to copy it to.

    the files is here /storage/.kodi/addons/ but I don't know about this, I never did!

    Share if work!

    januszmirek you use radarr/sonarr? Maybe this is causing you issue (image). If yes, try not rename files to test.

    Or if rtorrent have no especially function that you use, try to migrate for Transmission. I use it with external disk and had no issues about this.

    And if nothing this solve try uninstall and install again torrent client (and maybe LibreELEC itself), because here is working normal!

    (Raspberry Pi 3b hardware here)

    thoradia   januszmirek

    I searched and found this:

    035524.html

    How to delay the VCS startup after a reboot on RHEL 7.3


    Try add this on rtorrent.service

    Code
    1. TimeoutStartSec=100
    2. ExecStartPre=/bin/sleep 50


    before ExecStart command.


    I don't know if it work, I'm not at home now to test. This is to make the service wait 50s before starting.

    You can found the services on /.config/system.d


    About settings.json: I think this is the configuration file of Transmission, but don't know for sure.

    Another thing I noticed is it the download folder always change to default (/storage/.kodi/userdata/addon_data/service.transmission/downloads) when I reboot the system. At least in Transmission client.

    thoradia what you think about this issue and januszmirek issue too? You think is related with the torrent client and not with your add-ons?

    If yes where is the file settings.json of Transmission, maybe there I can change the folder (I searched but don't finded).

    You can always force an update by placing Image (Check if correct image) in the /storage/.update folder and rebooting

    Yeah! I can too change update of automatic to manual and choose the new in channel 9. But I think is weird it don't update automatic, isn't? The same happened to me in 9.0.0 update ?(

    I removed de -it, like suggested here and it worked :)

    Thanks again Iridium

    Now cron is this way

    Code
    1. 0 */8 * * * /storage/.kodi/addons/service.system.docker/bin/docker run --rm --name subliminal -v subliminal_cache:/usr/src/cache -v /var/media:/var/media dtroncy/rpi-subliminal --legendastv username password download -p legendastv -l pt-BR -a 1w /var/media/Seagate\ Backup\ Plus/Kodi/Filmes/ /var/media/Seagate\ Backup\ Plus/Kodi/Seriados/

    It's working now!

    When he made the modifications I mentioned before, he already fixed! Just doesn't work because I had a cache of the previous version. I cleaned

    docker run --rm --name subliminal -v subliminal_cache:/usr/src/cache -v /var/media:/var/media -it dtroncy/rpi-subliminal cache --clear-subliminal and now it working!

    Thank you very much Iridium for helping!


    For the record:

    For install it you need docker first Add-ons > Install from repository > LibreELEC Add-ons > Services > Docker

    and after just need to do docker pull dtroncy/rpi-subliminal

    This is how I use it on cron for searching for subtitles, in just one provider, in pt-BR language, at every 6 hours:

    Code
    1. 0 */6 * * * docker run --rm --name subliminal -v subliminal_cache:/usr/src/cache -v /var/media:/var/media -it dtroncy/rpi-subliminal --legendastv username password download -p legendastv -l pt-BR -a 1w /var/media/Seagate\ Backup\ Plus/Kodi/Filmes/ /var/media/Seagate\ Backup\ Plus/Kodi/Seriados/

    More info: Welcome to subliminal! — subliminal 2.1.0.dev documentation and GitHub - dtroncy/docker-rpi-subliminal: DockerFile for Subliminal on Raspberry PI

    I've noticed that the filename mentioned in "download -l en Creed\ \(2015\)\ Bluray-1080p.mkv"

    Yeah, I know this! I was using this directory because for test I just download one subtitles, and not all.

    And this is working, what is not working is just opensubtitles and legendastv. I'm brazilian and I prefer the subtitles of legendastv.


    I test your docker pull iridium748/rpi3-subliminal and for legendastv is working!

    This is my command in cron

    Code
    1. 0 */6 * * * docker run --rm --name subliminal -v subliminal_cache:/usr/src/cache -v /var/media:/var/media -it iridium748/rpi3-subliminal --legendastv username password download -p legendastv -l pt-BR -a 1w /var/media/Seagate\ Backup\ Plus/Kodi/


    Opensubtitles don't work because

    Quote

    error is related to SSL (https connection), most likely the docker image has no certificates at all, and can't validate any SSL connections.

    But legendastv was because it had no unrar and you put it on. Thank you! :)


    Do you know how to put SSL certificates on it?

    What I wanted you to do is only reboot rtorrent, not LibreELEC, because if the issue not persisted the problem would be with the storage not mounted yet.

    1. rtorrent service was stopped using systemctl stop service.rtorrent.service

    2. libreelec was rebooted using reboot now

    3. after system reboot, rtorrent service was working (without manual restart) and all current (seeded) torrents, currently downloading and other were fine without any issue

    But if you did this and the issue not persist your problem is another thing. Weird :/

    januszmirek sorry, but I don't understand this part: you reboot only rtorrent service, after you recheck the downloads manually, and the issue still persist?


    This issue with rechecking torrents and error after reboot is not happend with Transmission. I rebooted several times and don't see it again (this only happens one time to me). The issue that still persist here is on download folder, like I mentioned.