Posts by milhouse


    I got an Asustor NAS that contain the files.


    This isn't telling me anything. What OS is your server using, Windows or Linux?



    So here is another log GTOP
    Strange thing is i can ping it connect to it with putty but i can't connect back to my box in SMB.
    And after a while the network comes back.


    So there's nothing wrong with your network or the network interface on the LE client, but it sounds like your server is going to sleep and/or failing to respond after a period of inactivity.


    No idea if you've configured your server to sleep/suspend after xx minutes idle, if so you may need to look at configuring Wake On LAN in Kodi Settings > System > Power Saving.


    However if your server is running Windows, altering certain registry settings has been known to help smb (can't find them right now, could look if you confirm your NAS is using Windows).

    Vhanadium unfortunately that's not a *debug* log, nor is a log (debug or otherwise) likely to be useful before the problem has occurred - you need to capture the log after whatever is happening has happened (which would be tricky if your client really has lost network connectivity).


    How are you determining that the network connection is being lost? Can you ping the LibreELEC client? Are you able to connect to it using ssh?


    Are you streaming your TV shows from a NAS or some other server on your network, could that storage device be going to sleep?

    I guess the "Wait for network" isn't quite working in your case, for some reason.


    You could try adding the following in autostart.sh, it's what I use:

    Code
    1. # Wait for the network to come up...
    2. while [ -z "$(connmanctl state 2>/dev/null | grep State | grep -E "ready|online")" ]; do sleep 0.25; done; logger -t "$(basename $0)" "** Network is up **"


    As for the "route add" issue, by all means start another thread but a bump to busybox 1.25.1 might fix it. Unfortunately busybox.net is down right now so I've no clue what fixes and other changes are in 1.25.1.


    Also, please stop trying to contact me direct - I prefer to give public support on the forum. :)

    The underlying file system appears to have no bearing on the allocation roundup size - an RPi2 with 4096 byte ext4 block size still results in Windows 7 reporting 1024 bytes "Size on disk" for a 1 byte file.
    [hr]
    I'd suggest a separate post for the password query, this thread is about block size and it's marked solved.

    Huh? No, Kodi doesn't need the command line client - it uses a library. I only suggested the client to try and narrow down the issue. MySQL access is working fine in LE, it's in use by many other users. The problem here is almost certainly a server configuration error, no network at startup, or some other network issue. As requested, post a link to a full debug log.


    Is the SMB.conf of v7.90.008 ALPHA for C2 the same as on your RPi and NUC then?


    Yes, I'm using the default samba config - I haven't created a custom samba config in /storage/.config on either the RPi2 or NUC clients. Nor have I added any registry entries on the Windows 7 PC.



    have a look at this: Linux Performance - SambaWiki
    The third paragraph (from this URLs position) says that 1MB is default.


    I don't really understand that. Do the other systems use a different samba version then, so that your systems show the correct size?


    It appears that Windows 10 respects (or is confused by) the 1MB "allocation size" resulting in these wildly inaccurate "size on disk" calculations.


    This post suggests the problem was introduced with Windows 8.x.


    Try adding the following global entry to /storage/.config/samba.conf (copy the default from /etc/samba/smb.conf):

    Code
    1. allocation roundup size = 4096


    Restart your Odroid, and check if the size on disk reported by Windows is now a little more reasonable.


    This setting may need to be added to the default config in future.


    From smb.conf manual:



    Here's the output: NcXX
    It shows 1024, so this means it is bytes then?


    Yes, 1024 bytes, or 1KB, which is perfectly normal and reasonable.



    Here's a screenshot of the by you suggested new v7.90.008 ALPHA installation on my C2:
    ...
    It implies that Blocksize is 1MB for every file.


    Not really sure what's going on there but that might suggest a client (ie. Windows) issue as the "Size on disk" is definitely not what it is telling you.


    This is Windows 7 SP1 connecting to the LE Samba share of an RPi3:



    A NUC running LE Generic behaves the same as the RPi3.



    Is there any explanation for this?


    Another Redmond bug, perhaps?

    infinity85 please boot your Odroid C2 into LE after flashing with the latest official image, and while logged into the Odroid C2 provide the output of

    Code
    1. tune2fs -l /dev/mmcblk0p2 | pastebinit


    and paste the link.


    On Odroid the default ext4 block size should be 1024 bytes (1KB), on everything else (Wetek, RPi, Generic) it should be 4096 bytes (4KB).


    I'm not sure how you are seeing a block size of 1MB.

    I suppose the first question that needs answering: Is ssh already working, and have you simply assumed ssh is not working because you haven't found the ssh option?


    As already explained, you won't see the ssh enable/disable option when ssh has been added to the boot command line, because then the Settings add-on no longer controls the service - your boot command line does.


    Double check your boot command line (/flash/cmdline.txt for RPi/RPi2, /flash/syslinux.cfg [or EFI version] for Generic, no doubt something else for other projects - I've no idea what hardware you have) to ensure it doesn't include ssh. Paste the contents here if you're not sure.


    I've been testing this today with latest master builds of LibreELEC and as far as I can tell it behaves exactly as described here, so if you're seeing something different in 7.0.2 then it's possible the issue is already fixed.
    [hr]


    However if you enable ssh during the wizard process you do not get the same settings . services option.


    I'm not able to reproduce with latest master - if I enable or disable ssh in the wizard (with ssh not added to boot command line) then the enable/disable ssh option is always present in Settings > Services.

    Thanks. I haven't had a chance to go through your log in detail, but I suspect the LibreELEC systemd shutdown sequence needs tweaking to fully support any type of network booting.


    At the moment I believe the device (PC, RPi3 etc.) is hanging before restarting, most probably because the network (connmand) or some other vital network-related resource has been shut down too early, which is fairly bad news when booting over the network...