Posts by pipsen

    I am reworking Librespot and I would like some feedback.

    Thank you very much in advance for all the new features.

    I am using Librespot on a Intel NUC and the Movie/TV-Show Audio shall be output to HDMI (default KODI Setting).

    But the Librespot Audio shall be routed to 3,5mm Audio Jack (alsa).


    At the moment, I manuall change the settings in the service file:

    --backend alsa \

    --device front:CARD=PCH,DEV=0 \


    But after each Librespot Update, the changes are lost.


    Request:

    Please provide a GUI Setting for Audio routing / playback device. That would be awesome

    Okay, I installed version 119 successfully. My goal is like in former times:


    - Default Playback device for KODI is HDMI (KODI Audio Settings)

    - Librespot Playback device device shall be analog stereo out


    The setting is not available any more in librespot. What can I do now?


    Edit: Done!


    /.kodi/addons/service.librespot/bin/librespot.start

    => edit backend and device


    Works awesome!! Thank you

    Hi,


    ich have two different LibreELEC PCs running. Both are Updated to late release. For a few days, I have the same problem on both instances: When I want to enter LibreELEC Addon, there is a message "LibreELEC settings locked - Enter PIN". I have never set any PIN and have no idea, what is the correct PIN. I tried several default pins, but no way...


    Please don't get me wrong: This is NOT a Kodi Master Password.. the master password is disabled on both PCs.


    Can you help me? I have no chance to enter the addon any more :-(

    Hi,


    before updating LibreELEC to 9.1.002, there was a configuration item inside librespot addon to configure the audio playback device (independently from default audio device of KODI):


    Default Audio Out = HDMI (for video media playback on TV)

    Librespot Audio Out = Analog Audio Device (for Spotify music to stereo system)


    Not this configuration item has disappeared in Librespot :-(


    Currently the system starts the plugin with these paramters:


    Code
    1. librespot --backend pulseaudio --cache /storage/.kodi/userdata/addon_data/service.librespot/cache --device-type TV --disable-audio-cache --name Kodi (HTPC) --notify-kodi --disable-discovery


    If I try to change the backend to "alsa" to select hw:0,0 card (stereo audio), I get the message "invalid backend".


    Do you have an Idea how to route audio to analog audio out?

    I tried it now several times... sometimes it works fine.

    Now I am pretty sure, that the Download itself stucks... everytime at different positions of progress.

    The first time, it stucks at about 95%... that's why I did not realize that the http download timed out.


    I could upload the debug log, but it is exaclty the same. Not even one more line of log.


    And additionally, I see this problem:

    I added the "Custom Channel" yesterday. At this time, #0225 was the newest version, and I can see it, when I click on "Available Versions".


    But now.. one day later, when I click on "Available Versions", there is still #0225 the newest, although there is already a #0226 available online.


    The list of available versions seems not to be updated - just a reboot helps to get the new versions.

    Hi,


    I would like to update via LibreELEC GUI, not via manual Download and copy to "update" share.


    This is what I did:


    - Open LibreELEC Addon -> System

    - Automatic Updates: Manual

    - Custom Channel: Index of /builds/master/RPi2/

    - Update Channel: Milhouse-9.0

    - Click on Available Versions

    - Select the newest nightly build

    - Question: Current Version: #0222, New Version: #0225 Would you like to update LibreELEC now?

    - YES

    - Download starts and completed


    => Now tar file on whole File System

    => After Reboot, nothing happes.. still #0222


    Code
    1. ERROR: ## LibreELEC Addon ## oe::download_file(http://milhouse.libreelec.tv/builds/master/RPi2/LibreELEC-RPi2.arm-9.0-Milhouse-20180225210909-#0225-g1c7b478.tar, /storage/.kodi/temp/update_file) ## ERROR: (timeout('timed out',))
    2. ERROR: Traceback (most recent call last):
    3. File "/home/neil/projects/LibreELEC.tv/build.LibreELEC-RPi2.arm-9.0-devel/LibreELEC-settings-d658777/.install_pkg/usr/share/kodi/addons/service.libreelec.settings/oe.py", line 295, in download_file
    4. File "/usr/lib/python2.7/socket.py", line 384, in read
    5. File "/usr/lib/python2.7/httplib.py", line 597, in read
    6. File "/usr/lib/python2.7/socket.py", line 384, in read
    7. timeout: timed out


    Do you have the same Problem? Any ideas?


    Thank you


    Here is the logfile of a sample.file with DTS Sound:


    Creating audio stream (codec id: 86020, channels: 6, sample rate: 48000, no pass-through)


    why?? :-(