Posts by pletopia

    I compiled another image which include a series of patches for HDR on LSPCON. I don't have any devices with LSPCON so no idea if this will work. If anyone wanna try it don't forget to enable "Allow hardware acceleration - PRIME" in Settings-->Player.

    whoa .. whoa .. whoa ..


    is this a LibreELEC generic build with 4k HDR in development?? If so, I will be glad to help, i THINK i might have a LSPCON .. i have an 8th gen i3 NUC.

    Okay. Decided to play around with that box again tonight. First thing, I updated to latest build by placing your image in /storage/.update .. worked like a charm.


    Next, like with previous build and this build GUI audio works fine right off the bat. However I tried to play a video and nothing. So i wanted to test your instructions of making it like vanilla LibreELEC by placing "KODI_AE_SINK=ALSA+PULSE in /storage/.config/kodi.conf". There is no file like that on my system. I tried to make a file and got this error.


    bedroom:~ # nano /storage/.config/kodi.conf

    nano: error while loading shared libraries: libncurses.so.6: cannot open shared object file: No such file or directory


    What am I missing?

    Will give this one a whirl. I'll add a rom of some sort. Previous builds I guess you added something under Amiga and I never saw that screen before.


    As for audio. Can you explain a bit more how to do that? Also I was reading through old posts regarding audio in this thread. I know at one point you had it configured to actually use ALSA for Kodi but pulse audio outside of it. I normally use ALSA on other builds but i've seen posts here that with some config you can actually do passthru audio via pulseaudio. That would be something I want to do also but I couldn't find a good post on how to accomplish this.

    Loaded this image on my NUC: RetroELEC-Generic.x86_64-9.2-devel-20200406011507.img.gz


    Still no audio on loading Kodi. Was gonna try the same thing I did with previous build of starting ES and then going back into Kodi as that works to enable audio in Kodi however ES starts and I get an error "Can't find any systems! ..." when it starts. Quits to a desktop and then loads up again with same error message.


    EDIT:

    I tried this image now: RetroELEC-Generic.x86_64-9.2-devel-20200406103004.img.gz and still same thing. When you start up ES you get an error "Can't find any systems!...".

    Unfortunately I deleted my March build image so I can't go back to that X/

    Installed the latest generic image on my NUC (its an 8th gen i3). I get no sound in Kodi. Initially when i was messing around with it my audio choices were:

    Default,Default output device(pulseaudio)

    Built-in audio Digital stereo, hdmi(pulseaudio) <-- or something like that, I can't remember exactly now because currently it doesn't even let me go into the audio choice, its greyed out. When i was able to select an option neither one gave me gui sounds. Seems after attempting to play a video which didn't play audio it doesn't let me select anything anymore.


    No idea what else to provide info wise right now but here is my debug log after a fresh restart.

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    EDIT:

    So i decided to try to run a ROM in ES. It played with audio. Went back into Kodi and now the audio setting is no longer greyed out AND audio is working both in GUI and also in a movie. Reboot the NUC and no audio again and setting is greyed out.

    Before coming across this project I first stumbled across this one.


    LibreELEC-RR 9.x [ Emulationstation | Retroarch | Pegasus | DolphinQT | Moonlight | Chrome | Spotify ]


    I was just curious how they differ.


    EDIT:

    Played around with both using usb live sticks.

    I was able to get sound to work with the LibreELEC-RR properly (ie ALSA inside kodi so I can do passthrough) but no sound to come through with RetroELEC in kodi, but it did have sound coming through in the ROMs.

    Other thing I noticed, LibreELEC seems to have stalled in dev as no updates since Oct of '19 and the Kodi build is at 18.4 while RetroELEC has much more recent nightly's and even are running Kodi 18.6 which does bode better for the future.

    Cool. Will post there too.


    I'm curious because I feel limited by the Vero4k+. I know the RPi4 isn't ready yet for proper 4k hdr but its on its way. Plus I wouldn't be limited to 16GB either. Ideally there would be an x64 option as then I would have no problems running my intensive skin and large media collection.

    I was wondering how the performance of the Pi4 compares to the Vero 4k+. I ran CPUBench on my Vero and get roughly a score in the 13500-14000 range.

    I have no problems using my NUC booted into windows with HDR. The pi might be better but it’s newer (newer will always be better...) - you’ll also have the heat issue to deal with. My silent fanless 8th gen NUC is perfect for me at the moment, running much cooler than my pi 4 does just at idle...

    Any chance I can pick your brain PlatypusW? I have an 8th gen NUC and its not working out for me I feel. When I enable HDR in windows it looks horrible, so washed out and gray. Your not having this issue?

    Been a few months and a new build of Kodi since I last asked so I figured I'd check in. Any chance HDR is working yet? Was thinking of buying a 4k tv soon and not have to use a Vero 4k but rather a intel nuc.

    from my understanding Kodi can play 10bit HDR, but you won't see the HDR effect at your screen

    I think at this point I'll just hold off on Linux and 4k. When I do get my 4k TV i'll move my current htpc over to the bedroom and just get a Vero 4k. I know it works properly at this point as its been tested by someone I trust on his amazing LG OLED tv and the guy is a super snob when it comes to video quality :D