Solved: Playback issues for some full hd movies

  • Solution: If you have problems with the playback of (some) full hd movies, check if the file is VC-1 or MPEG-2 (an mkv can contain this!). Videos in H.264 should run fine, while all other movies will not play smoothly. You can purchase a license for under 5€ for VC-1 and MPEG-2 here. Add the License to your config.txt and the movies should run perfectly fine.

    Hi, I have the problem that some Full HD movies do not play smoothly. Others play fine after changing: Settings -> Player Settings -> Videos -> Adjust display refresh rate -> Always. I tested this on a Rasperry Pi 2 and 3 with LibreELEC 8.1.1. If you can fix this problem please let me know how to do it :)

  • Yes, it is 1920 × 1080 Pixels. Here is the data:

    Test 1.mkv

    Overall Bitrate (video): 20536 kBit/s

    Image Width: 1920

    Image Height: 1080

    Test 2.mkv

    Overall Bitrate (video): 26106 kBit/s

    Image Width: 1920

    Image Height: 1080

    You can download my test files from dropbox, they are only about 100MB together.

  • Can it have to do with hardware decoding? I saw that the Raspberry Pi 2 has hardware decoding for H.264 enabled automatically and that the license for VC-1 and MPEG-2 has to be purchased. Test 2.mkv is H.264, while Test 1.mkv is VC-1.

  • I was still checking it out, but YES! That can definitely be the case. I recently heard that those licenses only costs a few euro's. So I would definitely get those. As far as I could see the the video files were pretty similar.

    The second video file has even a higher bit rate then the first one and that plays fine like you say. So then one of the few things I could think of that could play a role is the type of codec. I noticed that in the properties of the first video file the compression says: Lossy. In other words, not compressed. That was one of the few thinks I noticed, but then again the bit rate of the second video is even higher and probably is compressed.

    I was kind of having the same problem. Last week I was testing 4K video files to see which hardware could handle it. A 4K mp4 file with a bit rate of nearly a 100Mbps (so 100.000Kbps) played fine, but a 4K mkv video file with a bit rate of about 60Mbps stuttered and buffered like crazy. I'm still planning to find out what causes this. :)

  • Omg thanks guys, I had been having trouble with this for a month, I did not know there is hardware/software decoding. I will definitely try it and leave a comment if it worked. Another thing I noticed is that movies run smoother on LibreELEC 8.1.1, but maybe it's just imagination.