no wakeup on scheduled recording from standby (generic x86_64 Libreelec 8.0.2)

  • Dear developers, community and anyone who can try to help me with this issue,


    my HTPC build on libreelec 8.0.2 does not want to wake up on scheduled recordings. It simply sleeps over... Logs are attached (with debug log activated)

    The schedules are set by TVHeadend Client, from the epg.

    If I set a recording, it generates an RTC alarm, I can check it over SSH by "cat /proc/driver/rtc"


    before setting a recording (the bios and rct time are 2 hours behind, probably because of my time zone):

    after setting a recording for 16:55:


    what I have already tried with no avail:

    - in BIOS HPET deactivated

    - in BIOS wakeup on RTC alarm activated

    - in sysconfig attached "hpet deactivated"

    - setting an alarm over SSH with "setwakeup.sh $(($(date +%s)+300))" works, generates an alarm in 5 Minutes (=setwakeup.sh works), PC does not wake up

    - tried to send PC manually into sleep, not over CEC-Adapter by switching off the TV, no difference


    My Hardware:

    MSI B250M Mortar

    Intel I3-7100 Kaby Lake, onboard GFx

    8 GB RAM Crucial


    could it be that the setwakeup.sh script writes an RCT but the bios is not taking it over?


    I do not understand too, why I am not able to set the correct system time in Bios. I can set it, but if I boot into Libreelec, it sets it back to 2 hours behind. Can that be the problem for not waking up?


    I would be thankful for any help or hint.

  • I have found the solution after >2 days of search, try and error... In bios, the item "wakeup handeled by" I had to set to "OS" and not by "bios" (this disables waking up by RCT though). I tried it before, I have no idea why it works now.