Supported HDMI modes for AVR

  • Hello everyone,


    I have LibreELEC v. 7.95.1 installed on a Raspberry Pi 2, which is connected via HDMI to a Yamaha RX-V473 AVR. The AVR is connected via HDMI to a Panasonic TV (TX-P50STW60).
    In the settings menu i cant choose other refresh rates than 50hz, 59.94hz and 60hz, even though I know that my TV supports e.g. 1920x1080p @ 24hz.


    If I connect the RPi directly to the TV i can choose way more refresh rates and resolutions in the settings menu.
    I guess my AVR doesnt tell the RPi what resolutions and refresh rates my tv supports, so a lot of options are missing.


    Is there some way to fix this? Can I manually set the supported HDMI modes?



    I hope somebody can help me, because its driving me nuts.


    Greetings,
    Champayne

  • Hello, i have exactly the same problem with a raspberry 3 with libreelec 7.0.3 connected to a onkyo tx-nr636 and a Panasonic Cxw804. Have you tried to enter the correct HDMI port under the libcec configuration? In my setup the avr is connected to the TV HDMI port 2. After reboot the raspberry i can select refresh rates like 23,976 ... also the refresh rate now switches to the correct rate that matches the movie fps.


    Have you tried this:


    Raspberry Pi FAQ - Official Kodi Wiki

    The post was edited 1 time, last by Knorz ().


  • Hello, i have exactly the same problem with a raspberry 3 with libreelec 7.0.3 connected to a onkyo tx-nr636 and a Panasonic Cxw804. Have you tried to enter the correct HDMI port under the libcec configuration? In my setup the avr is connected to the TV HDMI port 2. After reboot the raspberry i can select refresh rates like 23,976 ... also the refresh rate now switches to the correct rate that matches the movie fps.


    Have you tried this:


    Raspberry Pi FAQ - Official Kodi Wiki


    How can i configure libcec?


    About the edid files: i connected the Pi directly to the TV, then created the edid.dat file via tvservice -d edid.dat and forced the Pi to use that file. But when i connected the Pi back to the AVR i couldnt control it anymore via CEC. Also my TV switched HDMI sources when the Pi booted, even though the Pi wasnt connected to the TV.

  • Hello, you can configure the cec settings via settings -> system -> input devices -> peripherals. Revert any changes and start with the config.txt under /flash


    These are the steps that worked for me:


    Remount /flash as writeable:
     
    mount -o remount,rw /flash


    Edit the config.txt


    nano /flash/config.txt


    i added hdmi_edid_file=1 and uncomment hdmi_force_hotplug=1 , change or uncommnet nothing else


    exit nano and write changes.


    Next create the edid file with direct connection to your tv:


    tvservice -d edid.dat


    and copy the file to /flash


    cp edid.dat /flash


    make /flash readonly


    mount -o remount,ro /flash


    I have rebooted the pi several times, with tv on/off, avr on/off and have always all needed screenmodes like 24hz.

    The post was edited 1 time, last by Knorz ().


  • I did exactly that. Now i can use all of the screen modes of the TV, but when i connect the pi back to the avr i cant use my TVs remote anymore. Also when I boot the pi, my tv changes the source from HDMI2 (avr) to HDMI1 (where the pi was connected when i created the edid.dat file). So i guess using the edid.dat file messes up the cec configuration.


    Edit:
    Im pretty sure it has to do with the libcec config.
    If I run "echo scan | cec-client -s -d 1" it gives me the address of the connected devices.
    The pi has the address 2.2.0.0 when i dont force it to use the edid.dat file, and my TVs remote works flawlessly.
    But when i force the pi to use the edid.dat file the address changes to 1.0.0.0 and I cant use my remote anymore.


    Edit2:
    Well, after nothing was working I decided to change my HDMI cables... and would you believe it, it's working now :dodgy:
    I guess a slack joint or something caused the avr to not pass the available hdmi modes to the pi.
    Anyway, thanks for your help :)