Stuttering iptv simple

  • kodi.log.zipI have a problem with my
    - Rasperry PI 2
    - Acitvate MPEG HW-decoding
    - LibreELEC (Jarvis 16.1) v7.0.1
    - digib Sat-receiver
    - pvr iptv simple client


    which was not there with any version before libreelec (i use some of the latest milhouse-builds so far and still do).
    This issue is almost always there, especially for HD-channels:


    It looks like that the decoding speed is not fast enough, even that the CPU-cores are only loaded about 30% in total, I guess. Caused by this the icon showing the cue-speed in the top right corner appears for a short time and disappers again in an endless loop.
    I have also a video of this:



    It would be great, if somebody can help me.
    Oliver

    Edited once, last by newphreak ().

  • yesterday after first test with HD Channels over Tvheadend Server the Channels were stuttering at my Kodi 17.1 Test Pi.
    I then switched from MMAL to OMXPlayer and stuttering was gone ... try this switch please :-)


  • yesterday after first test with HD Channels over Tvheadend Server the Channels were stuttering at my Kodi 17.1 Test Pi.
    I then switched from MMAL to OMXPlayer and stuttering was gone ... try this switch please :-)


    Hi,
    thank you for your proposal but in my case it did not help ;-(


    Olli


  • HD or SD Channel?


    if SD do you have the mpeg codec ?


    Hello,
    yes. Without the codec HD did not run at all.
    With the OpenElec version (a milhouse build), which I currently still have to use (it has some other issues like memory leak when browse the movie library, I cannot refresh the library, ...) I do not have this problem at all.


    Sometimes the stutter-problem does not appear at all, but sadly it is there most of the time. Have you seen the linked video

    ? The decoding almost seems to work but the "cue-widget" pops up over and over again.


    Thank you
    Oliver


  • Thank you very much,
    here is the link: EUVJ
    For me there was no obvious entry in the logs.
    Today I will lso try tvheadend which I used some time ago with openelev but was not as "simple" like iptvsimple.


    Thank you again: I see, you know, how real unambigoues requirements looks like. I sadly was not able to find the right meaning of "paste site" from the 83.400.000 possibilities delivered by googles ;-)


    Olli


  • Are you using wifi or wired?


    I use TP Powerline 1200 adapters, but the satellite receiver and raspberry are connected to the same adapter. This works also when the second adapter, which is connect to my switch, is turned off. So I think the adapter works like a switch.
    When I copy data from my pc over the switch and the 2 powerline adapters I reach about 8MB/s.


    It also seams that the channel switch is a lot slower with libreelec (and also Openelec 6.0.3.) than with my old openelec millhouse installation.


    Br
    Olli