Tvheadend nightly builds for LE

  • Considering trsqr's OE implementation you might not need to specify the .ini path and don't need the quotation marks for the %f parameter:

    Quote

    Open your TVheadend web interface and go to tab Configuration -> Recording. Make sure the following is configured:

    • Remove all unsafe characters from filename: YES
    • Replace whitespace in title with '-': YES
    • Post-processor command: /storage/.kodi/addons/tools.comskip/bin/comskip %f

    Edited once, last by iophobia: Edit: Good thing is. I'm getting txt/edl files with both post-processor commands. However, recordings (ongoing/finished) don't appear in Kodi. Is there an updated TVH client needed? ().

  • Short question: comskip seems to work as files are generated. I don't see ongoing/finished recordings in KODI anymore, though. (Kodi 17.3 on Win 10 + Kodi/SPMC 17.3 on Shield TV). Is there a new client version needed? B/c TVHClient on Android has no trouble listing these recordings.

  • Now I remember why I ditched comskip a while ago. It just won't do the autoskip from the recordings view. Only seems to work from files menu with both .edl/.txt cutfiles. If anybody knows a fix, that'd be much appreciated.

  • Yes, if I play it from the recordings window. There was a fix for a supposed break in edl handling in 17.1 but I don't comprehend why it makes a difference whether you start it from Files or from Recordings. I walked back to 4.2 for now. Maybe I'll revisit in a few weeks.

  • Till now im running comskip on my windows desktop to search for comercials on the drive connected to Odroid-C2-LibreELEC.

    It it true that we now can run comskip/LibreELEC on the same mashine? this would be really really interesting for me!

  • we could try... ;-)

    it would be ok for me if the system is laggy a few minutes after the recorded movie, until comskip finished.

    most time i only record if im not at home. so laggy system while the odroid is searching commercials doesnt matter (IMHO).


    do you know how to try this? and in addition: how to trigger comskip automatically after a record stops/finishs?


  • /storage/.kodi/addons/service.tvheadend42/bin/comskip --ini=/storage/.kodi/userdata/addon_data/service.tvheadend42/comskip/comskip.ini "%f"

    comskip ini needs to be adjusted


    I change this in future version that you only need to insert comskip but currently this is the way it should work - like said i have not really a clue about comskip

  • i tried to test your newer versions of tvh but versions 4.3-291 and 4.3-295 did not work (got no access via webbrowser nor tvh-client).

    I am using 32bit build from Raybuntu (Libreelec 8.2)

  • i already expected this sort of answer ;) because you wrote this at the opening post of the thread: Nightlies (currently only LE7)


    but at Tvheadend nightly builds for LibreELEC you also have builds for LE8.

    So this is only compatible with official (64bit) release? Or which version i can use for testing comskip?


  • because you wrote this at the opening post of thethread: Nightlies (currently only LE7)

    ups forgotten to change this


    currently only building for LE8


    the problem is the 32bit, you can actually try if the WeTek_Play version work - ofc only for LE8 and possible not for 8.2 (never tried)

  • Follow Problem:

    /storage/.kodi/addons/service.tvheadend42/bin/tvheadend: error while loading shared libraries: libvdpau.so.1: cannot open shared object file: No such file or directory

    All relesaes after "Generic-tvheadend42-4.3-71" have this proplem.

    Running on VMWare "LibreELEC-Virtual.x86_64-8.0.2"

    Version 4.3-71 running fine.

    Any solution for my problem to use the newer builds?