[BUG] 1080p60 MP4 playback fault

  • dmesg Pastebinit :
    ObWN


    kodi log:
    01_KODI.log - Google Docs


    sample file :


    20161216_150801.mp4 - Google Drive


    i makes several videos with my Sam Galaxy s7e in 1080p60 mode. This files I can play without problem with pc with mpc-hc, wmp, kodi pc, and Android kodi and via directly dlna with LG smart TV.


    I have S905 minimx with latest LE
    when I try play file above, then after fresh restart maybe play the file, but later, when I play again, then frozen kodi ui (SSH still go), and maybe isn't played, frozen ui at first trying.
    After ui froze I try SSH reboot, but isn't success, just screen blacked out.


    as I early mentioned at le 010 topic, there are problems with playback rotated video files too
    (sample: 20161212_185109.mp4 - Google Drive )
    When I make videos with my phone stand mode, that isn't played back with LG.


    It seems the problem is with MP4 container. Maybe with rotate 90/180/270 degree
    when I convert it to MKV with mkvtoolnix, then played perfectly.


    I would be glad when this problems can be fixed :)
    thanks

  • I make a little trying.
    so with kiplus android and kodi work everything flawlessly (only the vertical video is little bit wider as normal)


    it work flawlessly too with libreelec 7.0.2.004.4 and kiplus (afl dvb-s2/s2 version}
    This le builded to kszaq's version, so something went wrong after 19th October with kszaq's build. (this date is the compile date afl's build)
    Or the Kernel is the older one, that's the way working.