Imon-lcd Driver

  • Hi,


    i am using your libreelec Jarvis image with an X86 PC. And i have a Soundgraph LCD/Remote in my Case ( Silverstone ML02MX ).
    And with this i have some Trouble. If I use the right config for the LCD (imon-lcd driver) I have a perfekt LCD. But my mce-remote
    makes trouble. If I went though the Menue or some Lists I can eg. move 4-5 Times down, and then the down button on my remote
    works like esc or back. So I checked this in the shell via "irw", and I can see exactly that the down button works with down, and suddenly
    there is one "back" signal although I didn't press the back button.
    First I have modified my as.xml with remoterepeat 800 to 1200, but this have no effekt. After all I decide to load another driver (imon).
    Here the remote works fine, but i have a blank LCD.
    Are there two drivers? One for remote and one for LCD, so that I can manually load the right LCD-Driver and the other Remote driver ?


    I'm not an driver expert, so I've decided to ask here.


    Thanks for any reply, and be tolerant with my english. School is more then 20 years behind, and english is not my favourite language ;)

    [hr]
    NAS:
    Cooler Master Elite 110
    ASRock Q1900-ITX
    4GB DDR3L-1333
    3x WD green 3TB
    1x 60GB BOOT-SSD
    OMV 2.x; TVHeadend 4.1.xx
    [hr]
    HTPC:
    Silverstone ML02MX
    ASRock QC5000-ITX/PH
    30GB Kingston SSDNow
    4GB DDR3-1600 DIMM
    LibreElec 7
    [hr]

  • I'm not sure really.


    Please post the output of the following commands

    Code
    1. dmesg | pastebinit


    and

    Code
    1. systemctl status | pastebinit
  • Hi,


    Here is the output when imon driver loaded.

    Code
    1. LibreELEC (official) Version: 7.0.2
    2. HTPC:~ # dmesg | pastebinit
    3. http://sprunge.us/jjIP
    4. HTPC:~ # systemctl status | pastebinit
    5. http://sprunge.us/hIDG
    6. HTPC:~ #


    And now if i load imon-lcd driver.

    Code
    1. LibreELEC (official) Version: 7.0.2
    2. HTPC:~ #  dmesg | pastebinit
    3. http://sprunge.us/UBfA
    4. HTPC:~ # systemctl status | pastebinit
    5. http://sprunge.us/iCFa
    6. HTPC:~ #


    And This is the output from "irw" with imon-lcd driver. I pressed only up and down in TV-List the Rest input is a failure.

    [hr]
    NAS:
    Cooler Master Elite 110
    ASRock Q1900-ITX
    4GB DDR3L-1333
    3x WD green 3TB
    1x 60GB BOOT-SSD
    OMV 2.x; TVHeadend 4.1.xx
    [hr]
    HTPC:
    Silverstone ML02MX
    ASRock QC5000-ITX/PH
    30GB Kingston SSDNow
    4GB DDR3-1600 DIMM
    LibreElec 7
    [hr]