Exchange outdated dvb-t2 firmware with read-only filesystem

  • Hello Everybody,

    from this forum I know that I have to update my WinTV Solo HD firmware to watch DVB-T2 correctly (the channels of one tvheadend mux are disturbed):
    DVB-T2 ZDF Mux in Leipzig/Germany at 482MHz not working - Tvheadend


    When I try to exchange the file dvb-demod-si2168-b40-01.fw on my Raspberry 4, I cannot because it's a read-only filesystem. I tried to remount root and I tried to mount the sd card on my Laptop. Neither helped.

    So how can I update the firmware file on my Raspberry Pi 4?



    kind regards,

    Tobias

  • use /storage/.config/firmware/


    You may have to create the folder if it doesn't exist

  • OK, but I also have to delete the old version in the order


    /usr/lib/kernel-overlays/base/lib/firmware/


    How can I do that?

  • OK, but I also have to delete the old version in the order


    /usr/lib/kernel-overlays/base/lib/firmware/


    How can I do that?

    you can't


    IIRC the firmware in /storage/.config/firmware will be preferred.

  • There is a lot output with dmsg. But the last ca 50 lines repeat this:

    em28xx 1-1.4.1:1.0: write to i2c device at 0xc8 failed with unknown error (status=128)


    I know from

    [SOLVED/WORKAROUND] Hauppauge SoloHD not working/new product ID - Tvheadend


    that em28xx is the corresponding kernel module for the firmware and the dvb-t2 stick.


    Is there a conflict between two firmware files?


    [7.125042] em28xx: Registered (Em28xx Input Extension) extension


    [ 7.391689] si2168 8-0064: firmware version: B 4.0.11

    [ 7.397775] si2157 9-0060: found a 'Silicon Labs Si2157-A30'

    [ 7.447904] si2157 9-0060: firmware version: 3.0.5



    Is it important that I use a USB hub with its own power supply?


    Files

    • dmesg_out.txt

      (41.74 kB, downloaded 11 times, last: )

    Edited 2 times, last by TobiasWe ().

  • I put the USB hub away and connected the DVB-T2 stick to the raspberry directly. Now none of the channels work correctly. Before only the ZDF Mux didn't work.


    Here is the dmesg output for the direct connection.

  • did you tired

    modprobe em28xx card=94
    echo "2040 8268" > /sys/bus/usb/drivers/em28xx/new_id


    if it works afterwards ? (reboot resets this settings)

  • I think now the DVB-T2 stick is defect. After all it doesn't funk on my laptop, which did at the very beginning!

  • No, I don't have any windows computer. But I feel the stick got more and more damaged. So after 482MHz, also the 498MHz didn't work. On the very begining I could watch everything on the laptop. Now it doesn't work on the laptop.

    So it got damaged in slow motion.

    I will try to buy the same Stick again. Then I will see that all drivers and the new stick will work, I think!



    Tobias