Configuring WiFi of second-strongest-network very hard; UI improvement suggestions

  • Dear LibreELEC community,


    Thanks for providing LibreELEC; my family uses it daily. I wanted to share an issue that might be a bug report or feature request, I'm not sure.


    Today I tried connecting the system to a WIFI network (Raspberry Pi 3 Model B Plus Rev 1.3 with LibreELEC 9.2.6 RPi2.arm installed). In daily use it is connected using a network cable. The use case is that on holiday I can connect the system to a wifi network from our windows laptop that shares its internet connection ("Mobile Hotspot"). This way, the cumbersome WiFi of the holiday park with additional login is handled through the laptop and other devices can connect through the laptop.


    In the living room, I disconnected the network cable, went in Kodi to settings, where it lists "System", then "LibreELEC". Under connections there was a long list (10+) of WiFi network. The strongest is the regular home one. The second strongest was from the Mobile Hotspot which I wanted to connect to. I use a wireless small keyboard. With arrows and enter/ok I could select that network... sort of. Because every couple of seconds it might do a re-scan, so that the selected item in the list of networks jumped to the top position. So probably on a couple of tries I tried setting up the wrong network. This was difficult to tell, because the big window for entering a password did not specifiy the network name


    There was no clear feedback if I entered the wrong password (I must have done so at least once in the many attempts` entering it for the wrong network).

    Also when navigating to the intended network, I pressed OK, and it just tried to connect but couldn't. I assumed I mistyped my password, but there was no clear way to re-enter it. If I press "OK" on a selected network, I got two options, "Connect" (which I tried before", and "Refresh". I hoped and believe that that one forgets the old password but it was not clear at all from the UI whether this was the case.


    After several attempts, in a few session with many minutes in total, suddenly it worked. At the end I tried being very quick in pressing "ok" after selecting the right network. I could see the WiFi configuration from SSH in a file "/storage/.cache/connman/wifi_b827ebd459bd_57494e2d4933553236453549424d522032373336_managed_psk/settings" to work


    My suggestions to the developer community is to make a few simple adjustments to the UI.

    1) In the window for entering a WiFi network password, show the WiFi network name.

    2) In the window with the choices what to do with a "click" on a WiFi network (connect, refresh) make clear that refresh will forget the old password.

    3) if you can, make the list of WiFi networks remember the previously selected item so that the focus does not jump around every time the list of networks is refreshed (This does not happen in Windows 10 for example).


    Again my appreciation for the development community :)