RPi 4 - After boot in Kodi "No Signal" (Bootmenu / RasberryOS visible)

  • Hi Members,


    since many weeks i have try to get my RPi-4 work in Kodi with my old Toshiba 37" Flatscreen (FullHD Support (MicroHDMI --> HDMI 2.0 Cable). The Pi shows the testpicture at boot up and the bootmenu. Also the RasberryOS works fine in Full-HD resulution on this TV. After i boot up libreELEC i see the LibreELEC-Logo and than i get the "No Signal" Massage from the TV. Same behavior when i boot into raspberry os and start the retrospectively installed Kodi from there. I´ve tried many settings in the config.txt include: hdmi_force_hotplug=1, hdmi_drive=2 etc.

    I´ve tried also a new libreELEC SD-Card with the same issue. I´ve tested out all HDMI-Ports of the TV... Seems that there is a problem with special settings in Kodi?!


    The same OS SD-Cards with LibreELEC / RaspberryOS runs on my other LG 55" Full-HD TV without any problems. (Same Cable, Power supply)

    Other PC-Systems works with this TV on HDMI without these problems.


    Is there only a HDMI to VGA Adapter a solution? The TV has an VGA-Port but i´ve don´t buy this adapter already.


    Can someone help to get my pi-4 work with Kodi at this TV?


    Many thanks!


    Tobi

  • Which LibreELEC version did you use? If it was 9.2.6 then please give LE10 beta1 a try.


    Note that the old hdmi_xxx settings in config.txt won't have any effect in LE10 - you can use eg "[email protected]" added to the end of cmdline.txt to select a different default mode though.


    so long,


    Hias

  • Hi Hias,


    thanks a lot for your fast response. Yes, it was 9.2.6. Ok, i go for a test with the beta at the weekend. Is there already a release date for the stable LE10?


    Greetings


    Tobi

  • We don't have a release date for stable LE10 - it'll be released when it's ready. RPi4 isn't fully feature complete yet (eg no 4kp60 or deinterlacing) and the missing bits will be added over time - so we'll probably call it "beta" for a while.


    so long,


    Hias

  • Ok, no problem for me with these missing features. I would be happy when it´s running on my Toshiba-TV. Thanks a lot for your support in this case and for your develop-commitment generally. I tell you if it works when i have tested it.


    Grettings


    Tobi

  • I can't wait until weekend to test LE10 Beta, so i try it directly. I'm very happy to tell you that kodi works now without any modifications. Many thanks for your help.

    Greetings Tobi:)

  • Hey there, I have the same issue, using LibreELEC-RPi4.arm-9.97.1.img.gz. If conect it to any computer screen it works fine, but if I connect it to my beamer, I get no signal after libreelec boot logo.


    I'd very grateful for any advice!-

    Tobi

  • I was wondering, since I have a signal while booting, would it even make sense to fidle with the config.txt?

  • in case anyone has the same issue, I "solved" it in the meantime. I connected the formerly non working beamer, as well as a supported screen to the pi4. Kodi launched on the supported screen, there I set the resolution to the beamer, and switched cables. Now also after a reboot with only the beamer connected, I get the signal...