virtual.adafruit-libraries

  • Hi,


    i am using a SSD1306 Display since Libreelec9 nightly it is not Working anymore.

    I do get this error Message


    Error Type: <class 'ModuleNotFoundError'>

    Error Contents: No module named 'Adafruit_BBIO'

    Traceback (most recent call last):

    File "/storage/.kodi/addons/script.oled.xbmc/main.py", line 68, in <module>

    disp = Adafruit_SSD1306.SSD1306_128_64(rst=RST, i2c_address=0x3C)

    File "/storage/.kodi/addons/virtual.adafruit-libraries/lib/Adafruit_SSD1306/SSD1306.py", line 242, in __init__

    super(SSD1306_128_64, self).__init__(128, 64, rst, dc, sclk, din, cs,

    File "/storage/.kodi/addons/virtual.adafruit-libraries/lib/Adafruit_SSD1306/SSD1306.py", line 85, in __init__

    self._gpio = GPIO.get_platform_gpio()

    File "/storage/.kodi/addons/virtual.adafruit-libraries/lib/Adafruit_GPIO/GPIO.py", line 420, in get_platform_gpio

    import Adafruit_BBIO.GPIO

    ModuleNotFoundError: No module named 'Adafruit_BBIO'

    -->End of Python script error report<--


    i do need really help

  • it worked in LE8 without any hiccups on LE9 it got a warning with Adafruit_BBIO.


    I testet the old libraries on raspbian with install using python3 install and it worked.

    why is it not supported? What can I do? Who can help?