TVheadend HTSP Client - server is unreachable / does not respond properly "log buffer full"

  • Hi


    Running LibreElec and TVHeadEnd on Rasp PI. Logs attached. Official builds and addon.

    Both previously worked. TVHeadend stopped working after a reboot after network went done. "Server is unreachable" "Server does not respond properly" in "eventlog"

    LibreElec works - TVHeadEnd doesn't start. Logs attached.

    Tried various configurations such as delayed start - no luck.

    I see log buffer full exception in logs.

    Any ideas ?


    thank you

    Files

    • kodi.log

      (113.41 kB, downloaded 16 times, last: )
  • hmm maybe your filesystem is full ?

    type df -h at the console, if not maybe there is some problem at the epg file, you can stop tvheadend at addons then rename (just in case) the epg file and then start the addon again



  • On restart this morning TV Head End did start with no changes. Can't think of any difference other than UK clocks just changed.


    Is the EPG file: epgdb.v2 ?

    Have renamed -

    Code
    LibreELEC:~/.kodi/userdata/addon_data/service.tvheadend42 # ls -alrt *epg* debug*
    -rw------- 1 root video 3106701 Oct 20 19:47 backup_epgdb.v2
    -rw-r--r-- 1 root root 614400 Oct 27 05:47 debug.txt_2020-10-27_05.47.06.txt
    -rw-r--r-- 1 root root 467592917 Oct 27 05:47 debug.txt_2020-10-27_05.47.15.txt
    -rw------- 1 root video 478767 Oct 27 05:48 epgdb.v2
    -rw-r--r-- 1 root root 489110949 Oct 27 05:49 debug.txt_2019-04-11_17.28.41.txt
    -rw-r--r-- 1 root video 697928794 Oct 27 05:59 debug.txt

    After reboot the log file (attached) is cleaner - there is still 'log buffer full' message but TV Head End is working.

  • I see debug.txt_2020-10-27_05.47.15.txt - did you enabled debug logging ? beware this could fill up your storage rather quickly


    Otherwise I have not really a idea what is going on.

    Maybe try to nuke all epg related stuff from the settings dir and populate the epg again (make backups !!!!) - disable tvh at addons, nuke, enable again.


    A other thing that could happen that you hit some bug that might be fixed at the current master version of Tvheadend.

    You could try a master build from Tvheadend nightly builds for LibreELEC and see what happens.

    Make backup of your userdata folder with all your Tvheadend settings ! There is no Tvh downgrade possible otherwise !

  • I did set debug on TV headend service. Switched off.

    Decided to do a re-install of TVheadend (fairly quick ) within libreelec and works ok now. thanks for the tips. will monitor if errors come back.